Access locked Keepass window not restricted

Chuba Kha
  • Chuba Kha

    Chuba Kha - 2012-11-08


    1> Add a new entry in your Keepass database, without saving it
    2> Leave the window open
    3> The workspace should be locked, according to the "inactivity lockout" option (sorry, bad english translation for french "Verrouiller l'espace de travail après une période d'inactivité de Keepass (en secondes)")
    4> Minutes later, click on the windows : a popup ask for you to save the database
    5> Just click "cancel", and you're back to the database without giving the password.

    I suppose this is not the correct behaviour, as it allows someone to have access to your password list, should you forget that you didn't save in the first place.


  • Paul

    Paul - 2012-11-08

    Turn on the option to Save on lock. Tools > Options > Advanced > Start and Exit, Automatically save….

    cheers, Paul

  • Chuba Kha

    Chuba Kha - 2012-11-09

    Ok thanks, I will do that.

    But on a side note, shouldn't this be treated as something to correct ? It would be wise to display the password prompt before restoring the access to the main window ?

    Maybe i'll lost a newly created password should the intruder really want to bug me, but that's life and my bad. And the rest of my database would stay unseen.


  • Chuba Kha

    Chuba Kha - 2012-11-09

    And please, my english is under construction, so please don't shout / laugh / post on Facebook….

  • Paul

    Paul - 2012-11-09

    KeePass does not lock if a window is open, or if the database has not been saved. The assumption is you are still working with it.

    I did laugh at the "post on facebook" suggestion.  ;-))

    cheers, Paul


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks