[APP] Extracting data stuck in eWallet

Alex
2010-12-23
2016-08-15
<< < 1 2 3 4 5 > >> (Page 4 of 5)
  • Uli Reinertz

    Uli Reinertz - 2013-04-14

    Hi Alex,

    thank you very much for your efforts. That was the solution for me! The correct version of ewalletDataLiberator.exe 0.9 now works faultlessly together with ewallet 7.4.2.32784

    I'm happy again! It's great to have this plugin, because I need it so badly to convert ewallet-files from pc to my nokia 701 because there is no ewallet-version for symbian.

    Thanks a lot!

     
  • Remusaber

    Remusaber - 2013-04-16

    Hi Alex,

    I attempted to using ewalletdataliberator 0.9 to extract wallet data from my old ewallet 7.2.0.30586 under windows 7 pro SP1 but have the attached errors.

    Greatly appreciate if you can comment and help.

    Thanks in advance!!

     
  • Remusaber

    Remusaber - 2013-04-17

    Hi Alex,

    Thanks for your quick response. Using the v0.10, the error occured in v0.9 gone and I can import the exported XML file into Keepass v.2.22.

    Thanks again for your great effort!!

     
  • Dominik Reichl

    Dominik Reichl - 2013-04-17

    v0.10 is now also available from the plugins page (note the plugins dialog in KeePass still shows 0.9 instead of 0.10, because the DLL version is 0.9).

     
    • Alex

      Alex - 2013-04-18

      Argh, could've sworn I updated the version number. Must have done it only for the extractor .exe and not the plugin .dll. I've updated that here:

      http://rapidshare.com/files/3855632712/eWalletDataLiberator.zip

      It's identical to the one you already made available, just with the version number on the plugin .dll bumped to match. Or you can just leave it as is and hopefully next time it needs to be updated for any reason I'll get it right and update both version numbers!

      Alex

       
  • Dominik Reichl

    Dominik Reichl - 2013-04-18

    Wonderful, thanks :-) The new 0.10 is now also available from the plugins page.

     
  • Tony

    Tony - 2013-06-05

    Great initiative - exactly what I have been waiting for!

    I'm having problems with 0.10 and eWallet 7.4.2.32784 on a Windows 7 64-bit system. When I run the exe file to launch eWallet, eWallet throws an unhandled exception error - object reference not set to an instance of an object. Please see attached.
    thanks

     
    • Alex

      Alex - 2013-06-05

      Hi, please could you give me a bit more detail on this. When you run the .exe file, before you see the exception, does the eWallet main window appear? Does a message box telling you to open your wallet file appear? Or any other message box?

      Did you open your wallet file before it crashed?

      Alex

       
  • Tony

    Tony - 2013-06-06

    Hi Alex, yes to your questions:

    1. run the exe file
    2. eWallet opens, overlaid by data liberator dialog saying go to eWallet, open the wallet...
    3. click on OK & I get the .Net framework exception error
    4. Click on continue or quit - eWallet shuts down

    I've also tried it on another PC with same results:
    Win 7 64-bit
    eWallet at lower version 7.4.1.32515

    Also, in case it is relevant, in both cases the eWallet data file is sitting in a dropbox folder. When I get a chance I'll test it to see if moving the data file to regular folder fixes the problem.

     
    Last edit: Tony 2013-06-06
  • Alex

    Alex - 2013-06-06

    Thanks for the details. From that, I suspect that you do not have a wallet file open when you click OK on the message box. Please open the wallet file first, then click OK. I know that's a bit weird, that normally you don't do anything while a message box is open, but it's hard to detect automatically when the wallet is ready for extraction, which is why I rely on this mechanism of asking you to click OK when it is.

    Here's an updated version (0.11) that I've tweaked to give an informative message box rather than crash under those circumstances:

    http://rapidshare.com/files/231203870/eWalletDataLiberator.zip

    Alex

     
    • Tony

      Tony - 2013-06-07

      I've just realised something:
      When I ran the liberator exe file and its associated dialog box pops open, the eWallet welcome dialog is launched - that is, it is prompting me for a password as if I was running eWallet for the first time. See attached screen grab. So this time I moved the liberator dialog box to one side (!!!) followed through with eWallet and let it create a new dummy file with a dummy password.

      I then opened up my regular eWallet file and clicked OK on the liberator dialog box and the XML export worked.

      I then tried Liberator again. This time, eWallet ran fine, and prompted me for my usual password.

      So, I assume that when Liberator is instantiating eWallet, something somewhere is looking for a wallet file in the default location - e.g. c:\users\<name>\Documents\ and if it can't find anything, it runs the new instance dialog. At least that's what happened for me.

      And as you say, I was so focused on what the dialog box was saying that I assumed it was modal, and that clicking on OK would make eWallet do its thing, not realising that the two are working in parallel. I suggest maybe in the dialog box you put more descriptive text for dumbasses such as me to say something like:

      1) Don't click on anything yet!
      2) Go to eWallet open the wallet or template you wish to extract the data from (including entering the password)
      3) Come back here and click OK

       
      Last edit: Tony 2013-06-07
      • Alex

        Alex - 2013-06-07

        Hmm... I'm a bit puzzled as to why eWallet would be showing you the first-run dialog like that. Unless you normally run eWallet as Elevated/Administrator, or otherwise as a different user? eWallet Data Liberator doesn't attempt to automatically look for a wallet file or have any default locations, it just launches eWallet and lets it do whatever it likes.

        I appreciate the message boxes aren't the nicest possible UI - it's a tough balance between making sure they are seen, but also trying to avoid them getting in the way of letting you use eWallet enough to open your wallet file. For v0.11 I think I improved things a bit by having it show another message box telling you that you haven't opened your wallet yet and to please do that now before clicking OK again. Better than crashing, anyway.

        Thanks for your detailed feedback,

        Alex

         
  • Dominik Reichl

    Dominik Reichl - 2013-06-08

    Thanks; 0.11 is now also available from the plugins page.

     
  • Tony

    Tony - 2013-09-01

    Hi Alex
    I tried to run version 0.11 today and am getting a stopped working error under Windows 7 64-bit. The problem signature says System.BadImageFormatException
    I noticed there were three .Net updates on August 30 - KB2836942, KB2836943 & KB2836939...could these be the culprit?
    eWallet version is 7.5.1.33537

    Also tried v0.11 under XP and no problems there, but it's against an older version of eWallet and .Net

    thanks
    Tony

     
    Last edit: Tony 2013-09-01
  • MichaelV

    MichaelV - 2013-09-02

    Hi,
    had the same problem as Tony. However 10 minutes earlier, v0.10 worked against eWallet 7.4.1.x, so I figure that the .net-updates are not the problem. Maybe there is a change again in eWallet 7.5.

    Thanks
    Michael

     
  • Alex

    Alex - 2013-09-07

    Hi, sorry for the delay replying.

    I've had a look at this, and for eWallet 7.5 they've moved to .net 4, which is why it can't be loaded by eWallet Data Liberator any more.

    I've done an update to v0.12 which should work with both .net 4 and .net 3.5, so theoretically continues to work with all v7 eWallet releases, including 7.5:

    http://rapidshare.com/files/3524104604/eWalletDataLiberator.zip

    Alex

     
    • Tony

      Tony - 2013-09-07

      Great job Alex, works like a charm now. Much appreciated!

       
  • Dominik Reichl

    Dominik Reichl - 2013-09-08

    Great, thanks; 0.12 is also available from the KeePass plugins page now.

     
  • Simone

    Simone - 2013-09-15

    Hi, since last update of the eWallet Android app rendered the app useless with continuous crash I'm trying to get away from it but have hundreds of cards to migrate and, of course, eWallet doesn't help to do that with those shitty txts.
    I tryed the 0.12 version of the plugin but we the latest eWallet 7.4.1.32515 it generates an empty xml after throwing the following error :

    L'applicazione non supporta il debug JIT.
    Ulteriori informazioni sono riportate in fondo al messaggio.

    ** Testo dell'eccezione **
    DBWalletDotNet.ErrnoException: ENOENT Standard C errno error in swprintf_s().
    in DBWalletDotNet.Card.DateFromFieldValue(String value)
    in eWalletDataLiberator.Program.<CreateXFields>d__5.MoveNext()
    in System.Xml.Linq.XContainer.AddContentSkipNotify(Object content)
    in eWalletDataLiberator.Program.WaitForEWallet()
    in System.Threading.ThreadHelper.ThreadStart_Context(Object state)
    in System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
    in System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
    in System.Threading.ThreadHelper.ThreadStart()

    ** Assembly caricati **
    mscorlib
    Versione assembly: 4.0.0.0
    Versione Win32: 4.0.30319.2012 (RTMLDR.030319-2000)
    Base di codice: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll


    eWalletDataLiberator
    Versione assembly: 0.12.0.0
    Versione Win32: 0.12.0.0
    Base di codice: file:///D:/Download/eWalletDataLiberator-0.12/eWalletDataLiberator.exe


    System.Windows.Forms
    Versione assembly: 4.0.0.0
    Versione Win32: 4.0.30319.2003 built by: RTMLDR
    Base di codice: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll


    System.Drawing
    Versione assembly: 4.0.0.0
    Versione Win32: 4.0.30319.2001 built by: RTMLDR
    Base di codice: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll


    System
    Versione assembly: 4.0.0.0
    Versione Win32: 4.0.30319.2001 built by: RTMLDR
    Base di codice: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll


    eWallet
    Versione assembly: 7.4.1.32515
    Versione Win32: 7.4.1.32515
    Base di codice: file:///C:/Program%20Files%20(x86)/Ilium%20Software/eWallet/eWallet.exe


    DevComponents.DotNetBar2
    Versione assembly: 10.0.0.9
    Versione Win32: 10.0.0.9
    Base di codice: file:///C:/Program%20Files%20(x86)/Ilium%20Software/eWallet/DevComponents.DotNetBar2.dll


    System.Core
    Versione assembly: 4.0.0.0
    Versione Win32: 4.0.30319.450 built by: RTMLDR
    Base di codice: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll


    DBWallet
    Versione assembly: 7.4.1.32515
    Versione Win32: 7,4,1,32515
    Base di codice: file:///C:/Program%20Files%20(x86)/Ilium%20Software/eWallet/DBWallet.dll


    msvcm90
    Versione assembly: 9.0.30729.6161
    Versione Win32: 9.00.30729.6161
    Base di codice: file:///C:/Windows/WinSxS/x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.6161_none_50934f2ebcb7eb57/msvcm90.dll


    Sync
    Versione assembly: 7.4.1.32515
    Versione Win32: 7,4,1,32515
    Base di codice: file:///C:/Program%20Files%20(x86)/Ilium%20Software/eWallet/Sync.dll


    System.Xml.Linq
    Versione assembly: 4.0.0.0
    Versione Win32: 4.0.30319.1 built by: RTMRel
    Base di codice: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll


    System.Xml
    Versione assembly: 4.0.0.0
    Versione Win32: 4.0.30319.2013 built by: RTMLDR
    Base di codice: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll


    WltSQLiteConverter
    Versione assembly: 7.4.1.32515
    Versione Win32: 7.4.1.32515
    Base di codice: file:///C:/Program%20Files%20(x86)/Ilium%20Software/eWallet/WltSQLiteConverter.dll


    System.Data.SQLite
    Versione assembly: 1.0.76.0
    Versione Win32: 1.0.76.0
    Base di codice: file:///C:/Program%20Files%20(x86)/Ilium%20Software/eWallet/System.Data.SQLite.dll


    mscorlib.resources
    Versione assembly: 4.0.0.0
    Versione Win32: 4.0.30319.235 (RTMGDR.030319-2300)
    Base di codice: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/mscorlib.resources/v4.0_4.0.0.0_it_b77a5c561934e089/mscorlib.resources.dll


    System.Data
    Versione assembly: 4.0.0.0
    Versione Win32: 4.0.30319.468 (RTMLDR.030319-4600)
    Base di codice: file:///C:/Windows/Microsoft.Net/assembly/GAC_32/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll


    System.Transactions
    Versione assembly: 4.0.0.0
    Versione Win32: 4.0.30319.1 (RTMRel.030319-0100)
    Base di codice: file:///C:/Windows/Microsoft.Net/assembly/GAC_32/System.Transactions/v4.0_4.0.0.0__b77a5c561934e089/System.Transactions.dll


    System.Data.DataSetExtensions
    Versione assembly: 4.0.0.0
    Versione Win32: 4.0.30319.1 built by: RTMRel
    Base di codice: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Data.DataSetExtensions/v4.0_4.0.0.0__b77a5c561934e089/System.Data.DataSetExtensions.dll


    Accessibility
    Versione assembly: 4.0.0.0
    Versione Win32: 4.0.30319.1 built by: RTMRel
    Base di codice: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll


    System.Windows.Forms.resources
    Versione assembly: 4.0.0.0
    Versione Win32: 4.0.30319.1 built by: RTMRel
    Base di codice: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms.resources/v4.0_4.0.0.0_it_b77a5c561934e089/System.Windows.Forms.resources.dll


    System.Configuration
    Versione assembly: 4.0.0.0
    Versione Win32: 4.0.30319.2013 (RTMLDR.030319-2000)
    Base di codice: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll


    PasswordGenerator
    Versione assembly: 7.4.1.32515
    Versione Win32: 7,4,1,32515
    Base di codice: file:///C:/Program%20Files%20(x86)/Ilium%20Software/eWallet/PasswordGenerator.dll


    l1l0pmoj
    Versione assembly: 4.0.0.0
    Versione Win32: 4.0.30319.2001 built by: RTMLDR
    Base di codice: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll


    ** Debug JIT **
    L'applicazione non supporta il debug JIT
    di Windows Form. Per ulteriori informazioni, contattare l'autore
    dell'applicazione.

    is it possible to fix? I would rather avoid to migrate hundreds of items manually

     
  • Alex

    Alex - 2013-09-15

    Hi Simone,

    There's a couple of things to try. First, as you are using eWallet 7.4 not 7.5, you can try the older version of eWallet Data Liberator, 0.11: http://rapidshare.com/files/231203870/eWalletDataLiberator.zip

    If installing it over 0.12, please also delete eWalletDataLiberator.exe.config which is only for 0.12, not 0.11.

    This will make it use .net 3.5 instead of .net 4.0 (so it matches what eWallet 7.4 normally runs under). I doubt this is the problem, as I've tested eWallet 7.4 with the latest version 0.12 under .net 4.0, but it's worth a try just to be sure.

    Secondly, the crash is occurring inside eWallet when the value of a date field is being requested. It's possible that there is some unexpected or unusual date value on one of your cards, I don't suppose you'd have any idea of a value or card that might be the problem?

    To investigate this line further, you could try creating a new wallet with just one card in it, populated with at least one Date field, then try using eWallet Data Liberator on that.

    If all else fails, I can add code to ignore the error and continue to export the rest of the data, but you would lose the date field(s) in question - this would only be a last resort, though, I'd much rather figure out what's going wrong and get a proper solution.

    Alex

     
  • Simone

    Simone - 2013-09-17

    Hey thanks for the help, succesfully migrated all cards, here what I did :

    used the version you recommended to carry out the operation, a newly created eWallet file would export without errors so I copied my wallet file several times leaving in each file only one category to figure out which one had elements giving it troubles.

    Comes out its not an issue of the exporter but an issue of the eWallet desktop program itself that corrupted some cards and is not capable to view them and therfore crashes,
    just sad to have wasted money on it (yes, i paid both desktop and android app as thinking to get better support and reliability and god i was wrong), thanks :)

     
    Last edit: Simone 2013-09-17
    • Alex

      Alex - 2013-09-18

      Great, glad to hear you got it working in the end! Thanks for letting me know.

      I hope you find KeePass to be a less crashy experience :-)

       
  • Toussaint OTTAVI

    Hi,

    I'm using "note" cards in eWallet. They do not contain any specific field, just plain text, in "notepad" mode. They are correctly imported, but into in an additional field called "note" in Advanced tab. This requires 3 clicks just to read content, and the window is ridiculously small.

    Would it be possible to import in the "notes" field, from the main tab ?

    Thank you in advance, and congratulations for your nice tool.*

    Kind regards

     
    Last edit: Toussaint OTTAVI 2014-01-21
  • Alex

    Alex - 2014-01-21

    That sounds like a good special-case. I've made Note cards behave in that way for v0.13, which can be downloaded here: http://rapidshare.com/share/C0B0F47FCF212C637C709AC530ED3960

    (I hope - RapidShare seems to have made some big changes since I last used them, so I'm not 100% sure it will work)

    Also, I made it a plgx now for hopefully better KeePass versions compatibility.

    Alex

     
<< < 1 2 3 4 5 > >> (Page 4 of 5)

Log in to post a comment.