[APP] Extracting data stuck in eWallet

Alex
2010-12-23
2016-08-15
<< < 1 2 3 4 5 > >> (Page 2 of 5)
  • Alex

    Alex - 2012-01-27

    Hmm… I hadn't updated that number, as the importer plugin itself hadn't changed, only the utility for extracting the eWallet to XML needed changing. I can see your point that it would be useful to use for update notification though, so for future updates (when the next version of eWallet comes out) I'll bump that version number too.

    Thanks,

    Alex

     
  • Anonymous - 2012-02-05

    Anybody experiencing an incompatible error message on launch of KeePAss2 about the eWallet Liberator.dll?  I keep getting this message with v 2.18.
    Thanks,
    Kevin

     
  • Paul

    Paul - 2012-02-05

    Do you have the latest version (0.5)?

    cheers, Paul

     
  • Anonymous - 2012-02-17

    yep, i have v 0.5.  Not sure why I keep getting the error.

     
  • Alex

    Alex - 2012-02-17

    Strange. Just to sanity-check, I've given it a quick go with 2.18 and it works fine for me. Does the error message give any details at all, or does it simply say "incompatible"?

     
  • kwarde

    kwarde - 2012-02-22

    It references that the plugging is incompatible. I am traveling for a week and will repost with the exact message when back.

     
  • Anonymous - 2012-02-26

    OK her is the exact error message:_
    The following plugin is incompatible with the current KeePass version:
    C:\Program Files (x86)\KeePass Password Safe
    2\eWalletLiberatedDataImporter.dll

    Have a look at the plugin's website for an appropriate version._

     
  • Alex

    Alex - 2012-02-26

    Please check that the file "C:\Program Files (x86)\KeePass Password Safe 2\KeePass.exe.config" exists, and if it does, open it with notepad (it is xml) and check that the element <bindingRedirect oldVersion="2.0.9.0-2.1.8.0" newVersion="2.1.8.18961" /> exists (in mine, it's about half way down, split over two lines).

     
  • Anonymous - 2012-02-27

    Everything checks as you stated, here is the code in KeePass.exe.config

    <configuration>
    <startup>
    <supportedRuntime version="v4.0" />
    <supportedRuntime version="v2.0.50727" />
    </startup>
    <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
    <dependentAssembly>
    <assemblyIdentity name="KeePass"
    publicKeyToken="fed2ed7716aecf5c"
    culture="neutral" />
    <bindingRedirect oldVersion="2.0.9.0-2.1.8.0"
    newVersion="2.1.8.18961" />
    </dependentAssembly>
    </assemblyBinding>
    <enforceFIPSPolicy enabled="false" />
    </runtime>
    </configuration>

     
  • Alex

    Alex - 2012-02-27

    Yes, that looks right to me too. The only other thing I can think of is that you don't have .NET Framework 3.5 installed (only version 4, perhaps), but that doesn't make a lot of sense as then the extractor program for getting the data out of eWallet wouldn't have run either.

    I'm afraid I'm out of ideas at this point, I don't know why KeePass won't load the dll for you.

     
  • Luckyrat

    Luckyrat - 2012-02-27

    Alex, It might be worth testing the plugin on .NET 4 Client Profile. I found that with KeePassRPC.plgx one of the dependent DLLs would not execute in .NET 4 CP because it is a cut down library compared to .NET 2/3.5.

    Most .NET 4 users will have CP only but developers are likely to have the full version installed.

    Kevin may be able to work around this by deleting the "<supportedRuntime version="v4.0" />" line from the KeePass config file or by downloading the full .NET 4 runtime from Microsoft.

    Chris

     
  • Anonymous - 2012-02-28

    OK, I did all of the above but think it was my fault.  Idiot me… I must have not unzipped the dll file but just dropped it into the KeePass folder.  I replaced the original dll with a properly unzipped version and works great.  Sorry about the run around.

     
  • Alex

    Alex - 2012-02-28

    I'm glad you figured it out, thanks for letting us know!

     
  • Alex

    Alex - 2012-03-29

    For anyone else finding this thread having difficulty with KeePass not loading the eWalletLiberatedDataImporter.dll plugin, lukyrat's suggestion of deleting the line: <supportedRuntime version="v4.0" /> from KeePass.config.exe is now known to have worked for at least one person.

    This would force KeePass to load using the .NET 3.5 CLR rather than the 4. There shouldn't be any difference between client profile and full .net framework, I've checked that the plugin doesn't use anything that isn't part of the client profile.

    It is compiled in .NET 3.5, though, so that's probably why it's happier if you remove the 4.0 supported runtime line (at a guess). You can always put the line back in after doing the import, in any case.

     
  • ringhio80

    ringhio80 - 2012-04-27

    Hi Alex, can you update the plug-in to work with the latest eWallet version 7.3.2.31911??
    I was not able to find eWallet  version working with your latest plugin anywhere.
    Many thanks

     
  • Alex

    Alex - 2012-04-27

    (sorry, I meant 7.3.2.31911 only, of course!)

     
  • ringhio80

    ringhio80 - 2012-04-27

    cheers mate !

     
  • Dominik Reichl

    Dominik Reichl - 2012-04-27

    I've updated the plugins page, thanks :-)

     
  • csowers

    csowers - 2012-07-01

    Hi! Will you be updating this plugin to work with the latest eWallet version of 7.4.0.32135?

    Thanks!
    Chuck

     
  • Albert

    Albert - 2012-07-01

    Hello Alex.

    I am sorry to bug you, but I am not smart enough to compile it myself …

    There is (again) a new version of eWallet. I am trying to 'get liberated', so please, when you have a little spare time, can you please update the exe? Seems impossible to find previous versions of eWallet setup.

    Thank you in advance. Regards from Luxembourg,
    Albert

     
  • Alex

    Alex - 2012-07-01

    Yes, absolutely. I don't tend to find out about updates to eWallet until someone posts here asking about it, but as long as the updates continue to be minor it doesn't take long to patch up the liberator.

    Here's a version that will work with 7.4.0.32135 only: https://rapidshare.com/files/3701307445/eWalletDataLiberator.zip

    Alex

     
  • csowers

    csowers - 2012-07-02

    Thank you Alex!!!

    I downloaded the version you posted the link to in the above message (for eWallet 7.4.0.32135). The extracting part worked fine, and it created the .xml perfectly. I then put the eWalletLiberatedDataImporter.dll file in the KeePas program folder as instructed. Upon running KeePass 2.19, I recieved the following error dialog box:


       The following plugin is incompatible with the current KeePass version:
       C:\Program Files (x86)\KeePass Password Safe 2\eWalletLiberatedDataImporter.dll

       Have a look at the plugin's website for an appropriate version.

                                                                                                                   OK

    Thanks for any help in figuring this out!
    Chuck

     
  • Paul

    Paul - 2012-07-02

    Download KeePass V2.18 portable.
    Rename the existing KeePass.exe to KeePass2.19.exe
    Extract KeePass.exe from the 2.18 portable zip file to the KeePass directory.
    Import the data.
    Delete 2.18 and rename 2.19.

    cheers, Paul

     
  • Albert

    Albert - 2012-07-02

    Thank you Alex, worked like a charm. The export part, I mean. For the import, however, I have to report that I have the same problem as Chuck (plugin is incompatible).

    I followed Paul's advice, but had the same result. I also tried 2.17, both on win64 and win32.

    Albert

     
<< < 1 2 3 4 5 > >> (Page 2 of 5)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks