Ctrl-Alt-A Hotkey has suddenly stopped working

permon
2013-05-11
2013-05-14
  • permon

    permon - 2013-05-11

    Yesterday the Ctrl-Alt-A hot-key (and Ctrl-V) suddenly stopped working . This is so across IE8,Firefox 20.0.1, and Google Chrome 26.0.1410 . Drag and Drop of username and password is still working . The KeePass options/integration dialogue box shows the hot-key correctly set. I have checked the KeePass XML file in the user application data directory and it shows Hotkeyglobalautotype as 393281 - the XML file in the program directory has entries only for preferuserconfiguration which shows as true.

    Oddly Ctrl-alt-K hotkey to show the KeePass window is working.

    Using KeePass 2.22, Windows XP Home.

    I have already tried re-installing to no avail - Any ideas ?

     
    Last edit: permon 2013-05-11
  • wellread1

    wellread1 - 2013-05-11

    Have you tried changing it to a different key combination? Also, I used to run issues like this on XP if I hadn't rebooted in a long time.

     
  • permon

    permon - 2013-05-11

    Thanks for the fast reply.

    Yes I had tried changing the combination to Ctrl-Alt-Q but tried again and rebooted - still no success.

     
  • wellread1

    wellread1 - 2013-05-11

    Is it possible that you accidentally unchecked one of the settings affecting global auto-type in Tools>Options>Advaced(tab)>Auto-Type(section) e.g. "An entry matches if its title is contained in the target window title".

    Did you install or upgrade any software just before the problem occurred?

     
  • Paul

    Paul - 2013-05-12

    If Ctrl V also doesn't work then something may be blocking Auto-Type. Have you tested Ctrl V in Notepad?
    Have you installed / updated any software recently?

    cheers, Paul

     
  • permon

    permon - 2013-05-12

    Solved ! Whilst learning to use the auto-type feature I had been trying to change the default auto-type sequence to remove automatic submission by removing the final {ENTER}. To apply it to the whole database I edited the database's root folder setting (Edit group/auto-type tab) accordingly. However I must also have set auto-type on the group behaviour tab to Disabled - I have now re-enabled it and all is well again . Paul you were right - something was blocking auto-type - ME!!. Thanks to both of you for your help which helped me track down the cause.

    On an aside I notice that even on the root folder it is possible to set "inherit default auto-type sequence from parent group". As this is the root folder surely there is no parent group . If it was so set what default would apply ?

     
  • Paul

    Paul - 2013-05-13

    Why don't you test it and let us know what happens?

    cheers, Paul

     
  • permon

    permon - 2013-05-13

    Point taken !

    Seems it (i.e setting root group auto-type to inherit from parent group) defaults to {Username}{TAB}{Password}{ENTER} which is therefore the overall database default for auto-type.

    So to save others time :
    1. To set all entries in the database to autofill username+password and autosubmit :
    a) Set the root group auto-type tab to inherit from parent group or specifically set the root group to override default sequence and specify the sequence as {Username}{TAB}{Password}{ENTER}
    b) Set each subgroup to inherit auto-type from parent group
    c) Leave each entry to inherit default auto type sequence from group
    2. To set all entries in the database to autofill username+password only (ie no autosubmit):
    a) Set the root group auto-type tab to override default sequence and specify the sequence as {Username}{TAB}{Password}
    b) Set each subgroup to inherit auto-type from parent group
    c) Leave each entry to inherit default auto type sequence from group

    The auto-type sequence can be tailored at group level and/or entry level

    Also auto-type sequence can be enabled/disabled at group level on the group/edit behaviour tab ( incl at root-group level as I learned to my cost above)

    Padraig

     
    Last edit: permon 2013-05-13
  • Paul

    Paul - 2013-05-14

    Step 1 is the default so you don't need to change the values.

    cheers, Paul

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks