KeePass 2.

Sam Mah
  • Sam Mah

    Sam Mah - 2013-02-19

    I can't get KeePass 2.21 (or any older version) to AutoType (ctrl-v) with IE9 (9.0.8112.16421), update versions 9.0.13.
    1. In KP, I select the title, hit ctrl-u to open the webpage in IE9.
    2. make sure the cursor is flashing in the login box.
    3. Switch to KP, and make sure my title is highlighted, and press ctrl-v
    4. At this point, KP loses focus, but IE9 does not come forward, it stays in the background, behind KP.
    5. Open Notepad, and try ctrl-v and it works, Notepad comes into focus and autotypes.
    6. Try Opera, and it works with the same website.
    7. Tried the sample form in IE9, no luck.
    8. tried different websites, no luck.

    • This is a new, re-installation of Win7x64 Pro, and it was working before.
    • I've installed 2.21 with KeePass-2.21-Setup.exe.
    • I've 'reset IE9' under security to default, same thing.

    I've used KP for a long time, and it's worked until now.
    What else can i try?

  • develop1

    develop1 - 2013-02-19

    since your starting within KP and using ctrl-u to launch the URL
    you could try current-record autotype.

    before you try using it, first make sure its defined.
    go into KP, "tools" "options" "intergration"
    and make sure a key stroke is defined for

    "autotype selected entry" Example LShift, Lctrl, A

    once you have the above defined you'll never need to do so again.
    to use it.

    your step 1 remains the same.
    your step 2 remains the same
    your step 3 changes. do NOT switch back to KP instead remain focus at the same point as you had in your step 2 and simply issue your LShift, Lctrl, A. This should perform the autotype of the KP record you last touch which with 100% certainity is the record you want because had just highlighted the desired rec and used ctrl-u to launch the URL.

    while the above might not solve the immediate question you asked, it might make KP effective for you once again.

  • Sam Mah

    Sam Mah - 2013-02-19

    Wow, great tip! One more reason for me to KEEP using KP.
    I narrowed it down. I've got an HP laptop that run HP Protect Security Manager, and it always shows an icon on every webpage, to help one register that webapge with HP Security Manager. Anyways, I went into the settings of HP Security Manager, and unchecked 'Display Icon on webpage', so now, KP works great, and better with your tip!


Log in to post a comment.