KeePass and Chrome

Dupree
2010-07-30
2014-06-06
  • Dupree

    Dupree - 2010-07-30

    Sorry if this has been posted before, but I can't find it…
    So Keepass and Chrome works just fine for logins that are part of the webpage,  But for those logins that (in IE and FF) cause a 2nd and separate window to pop-up (Authentication is usually the title of it) keepass will not work.

    It seems that the new window, in Chrome, is actually not a separate window at all and is considered part of the browser window.  As you have to log in the page first the tab/titlebar reflects the original location not the "new" location (not a problem for IE / FF since the authentication window has it's own title and then I just have to tell KeePass which one of 4-5 passwords that match to use). 

    I hope this is clear and that someone can point me in the direction of resolution.

     
  • Paul

    Paul - 2010-07-31

    KeePass does work as long as you use an Auto-Type-Window, or target window setting to cover the "Authentication Required" window.

    cheers, Paul

     
  • Ian

    Ian - 2010-08-19

    The problem with chrome is that the Authentication required window is not a window at all; it is html inside the page itself. Since the title of this "popin" window is not propagated to the tab, there is no way for KeePass to identify when it is up.

     
  • Paul

    Paul - 2010-08-19

    There will still be a title that KeePass can match. Add that to the entry and GAT will be fine.

    cheers, Paul

     
  • Ian

    Ian - 2010-08-19

    No, there is no title for KeePass to match. In fact, the title is the last title that the window had, which is entirely unhelpful.

    To be honest, this should be filed as a bug against google chrome, as there is nothing keepass can do to change it :)

    See the following image:

     
  • Paul

    Paul - 2010-08-19

    When you have the login page up, open KeePass and edit the entry. Select Tools and list the window titles available.

    cheers, Paul

     
  • Ben Jones

    Ben Jones - 2010-09-30

    Paul - Ian is right - even by using the special tool in the entry dialog the authentication window is not listed. Even if I manually enter 'Authentication Required' as a window match, KeyPass can't see it - because the popup window is not a separate window.

    Anyone figured out how to resolve this for Chrome?

     
  • Paul

    Paul - 2010-10-03

    You need to use the title of the web page.

    Maybe chrome has a plug-in to change the title?

    cheers, Paul

     
  • Ben Jones

    Ben Jones - 2010-10-03

    There is a plugin for Chrome which puts the host address in the title (HostTitle). But this doesn't help unfortunately. The authentication popup is shown before you actually get to the address you are loading. And as stated above the authentication popup is not a 'window' in Chrome - so KeePass doesn't even 'see' it.

     
  • Paul

    Paul - 2010-10-03

    Then it's 2 entries with the same target window.

    cheers, Paul

     
  • Ben Jones

    Ben Jones - 2010-10-03

    Thanks Paul - the problem seems to be that the page is not loaded, or the window title is not updated, until after authentication is completed. So when you first navigate to a website that has this type of authentication the window title is whatever is currently open, or in the windows title - and thus can't be used for GAT. I just think it is a flaw with the way Chrome shows these popup windows - GAT is not an option unfortunately.

     
  • Paul

    Paul - 2010-10-03

    If this is the first window you get when you navigate to that site, try creating a local page that just re-directs to the page in question, but puts a title in before the re-direct?

    cheers, Paul

     
  • Ben Jones

    Ben Jones - 2010-10-04

    Great idea Paul! That has worked a treat.

     
  • Paul

    Paul - 2010-10-04

    Yay!!!

     
  • Anonymous - 2012-09-13

    I have the same problem. I have no idea how to create a local page. Any suggestions?

    Bob

     
  • Paul

    Paul - 2012-09-13

    A local page is a file with a name ending in HTM that contains HTML code. Something like this.

    <html>
    <head>
    <title>My Login Page</title>
    <meta http-equiv="REFRESH" content="0;url=http://www.domain.com/LoginPage">
    </head>
    <body>
    Re-directing to login page.
    </body>
    </html>
    

    Replace the "http://….." bit with the URL of your login page, save the file and then double click on it.

    cheers, Paul

     
    • oivindhoem

      oivindhoem - 2013-11-04

      Could you please give a detailed description on how to make this work for the beginners. Would be much appreciated!
      Do you make a new document as an attachment to your password entry and somehow refer to that?

      Cheers Øivind

       
  • Paul

    Paul - 2013-11-05
    1. Open Notepad.
    2. Copy and paste the text from the post above, changing the title and URL as required.
    3. Click File > Save.
    4. Save the file to your Desktop with a name appropriate for your site. The file name must end with ".html". e.g. BankLogin.html
    5. Double click the file on your Desktop to open the login page.

    cheers, Paul

     
  • Matidio

    Matidio - 2014-06-06

    The local page solution is a work around but cannot be the final solution. As some of us have a lot of pages which presents themselves with the authentication pop up we are stuck with a non working auto type.
    I see that this is not a Keepass problem as Chrome presents a window which can't be identified by Keepass but cant't we find another solution? Filing a bug against Chrome doesn't seem to be an option as this popup is around since a while.

     
  • Horst

    Horst - 2014-06-06

    Try the WebAutoType plugin.
    This allows to match against the URLs and not the Windows title.
    Works fine for me in actual Firefox and Chrome.

     
  • Matidio

    Matidio - 2014-06-06

    @Horst
    As you can see in the example some comments above the URL is not shown so it doesn't work and unfortunately I have a bunch of these pages and none of them shows the URL ....
    Neither the URL nor the the windows title is shown until the page is not completely loaded. This is the default behavior of Chrome. I didn't find neither a plugin nor another (simpler) workaround to resolve this problem.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks