introducing debian/ubuntu keepass2 package

2011-04-25
2017-01-03
<< < 1 2 3 4 > >> (Page 3 of 4)
  • Andrew Kenney

    Andrew Kenney - 2012-07-11

    I started using Linux Mint on my laptop a couple weeks ago.  Soon after, I installed Keepass2 from the repositories and it worked just fine with my .kdbx database from the windoz version of Keepass.  I was a happy camper!!

    About 3 days ago, I did an update to my Linux Mint installation, which had been pending from the day I installed Mint.  Being half a nob, I went against my better judgement and did the update.  Now, Keepass2 won't start!  I'm using the gui, not the cli so, I can only say the gui version isn't working.  I select the program from the Menu and  the HDD drive light flashes for a few seconds, the mouse pointer changes to the waiting wheel for a few seconds, and then……… nothing!  No Keepass interface, no messages, no nothing!  It's as if I never asked it to open the program.   The machine continues to operate normally with no other hiccups.  It does the same thing when I try it again, and again…..

    When I look at the dependencies for Keepass2, it says it needs mono-runtime 2.10.1.  I notice in Synaptic that the installed version is 2.10.8.1.  I suspect Mono may have been updated which could have caused this problem but, I honestly don't know.  Although I like using Linux, I really am still a nob comparred to most of the folks on these forums.

    I don't know how to check to see if Mono was one of the packages recently updated and, I also wouldn't know how to roll it back to the previous version so, please keep this in mind if you are going to suggested something for me to do.  I will most likely need a step-by-step guide.  Thanks!

    Andy
    Using Linux Mint 13 - Cinnamon - x86-32

     
  • Julian Taylor

    Julian Taylor - 2012-07-11

    what kind of an upgrade did you do? from one distribution to the next or just a regular stable update which occur pretty much daily?

    please open a terminal and type keepass2 and copy the output.

     
  • Paul

    Paul - 2012-07-12

    First make a copy of the database somewhere safe. Can't be too careful.

    cheers, Paul

     
  • Anonymous - 2012-09-07

    I have the same problem using Linux Mint 13 with Mate.

    This only happens if I start KeePass minimized to tray. It doesn't happen if I start it with a open window.

    It minimizes to the taskbar if I choose minimize to tray. The window restore with a completely blank canvas after having been minimized to tray.

    All behavior is normal if I don't minimize to tray. Wonder why this is different in Mint…

     
  • Don Tingsley

    Don Tingsley - 2012-10-02

    I repro'd this easily with Ubuntu Keepass 2.18. I created a new file and saved to the desktop. Set master password as "test". When I close and reopen the same kdbx file, if I type in "text", works fine. If I hit  backspace after the last "t" and then retype "t", then hit "ok" I get the keyfile error, even though no keyfile is set and the password should be identical.

     
  • Don Tingsley

    Don Tingsley - 2012-10-02

    Is there also a charachter limit?

     
  • BWMerlin

    BWMerlin - 2012-10-13

    I have installed this package and I can open up and get my passwords etc but the keepass plugin that I need to work is not being detected.  The plugin in question is keepasshttp and when I go view plugins it is simply not listed.  Following the instructions (https://github.com/pfn/keepasshttp) I have copied the two required dll files as well the plugin file to /usr/lib/keepass2 but that has not worked for me.  How do I go about getting keepass to detect the plugin?

    Thanks.

     
  • BWMerlin

    BWMerlin - 2012-10-13

    Please ignore my above post (can't find the delete or edit option) but I have fixed my problem (I did not download the required .dll files correctly and that is why they were not showing up in keepass) and everything is now working correctly.

     
  • Scott

    Scott - 2013-03-02

    @Julian - I'm a newb using Ubuntu and I see the package is stuck on 2.19. I'm assuming that your efforts are key to releases for Ubuntu. Is there anything we can do to help get the project caught up to 2.21? I see note of xsel to improve clipboard handling. Is this package so different that is failed to get past experimental, or did you just get busy on other stuff? Thanks for your efforts btw.

    That said I do see this but have no idea what is means for Ubuntu (http://anonscm.debian.org/gitweb/?p=pkg-cli-apps/packages/keepass2.git;a=summary)

     
    Last edit: Scott 2013-03-02
    • David Lechner

      David Lechner - 2013-05-19

      You can subscribe to Julian's PPA to get the latest version of KeePass

      sudo apt-add-repository ppa:jtaylor/keepass
      sudo apt-get update
      sudo apt-get install keepass2
      
       
  • Miles

    Miles - 2013-07-11

    Is this PPA no longer being maintained? I tried to add the PPA to Linux Mint and it could not find it.

     
  • Miles

    Miles - 2013-07-19

    I should have specified I am using Linux Mint Debian Edition. Will the PPA work with LMDE? If not how else could I install Keepass for Debian?

     
    • David Lechner

      David Lechner - 2013-07-19

      The Debian edition may not like the Ubuntu distro names in the PPA. I am guessing that this is why it is not working.

      Other options would be to 1) Just download the portable version from the KeePass website. You would have to make your own .desktop file if you want to add it to the menu or have a desktop shortcut, but it works just fine. Or 2) Manually download and install the "experimental" package from http://packages.debian.org/experimental/keepass2

       
      • Miles

        Miles - 2013-07-20

        Thanks. I installed the 2.23 portable version. Works great and I don't have to use the PPA now on LMDE.

         
  • rob-sp

    rob-sp - 2013-08-12

    Hi, I have a problem with global auto-type. I can't get global auto-type to respond.

    I'm running linux mint 13 mate.

    I have installed the latest keepass2 from the ppa: https://launchpad.net/~jtaylor/+archive/keepass
    I have also installed xdotool which is: 2.20110530.1-3ubuntu1

    I have set a global hot key and have tried:
    mono /usr/lib/keepass2/KeePass.exe --auto-type
    /usr/lib/keepass2/KeePass.exe --auto-type
    mono /usr/bin/keepass2 --auto-type
    /usr/bin/keepass2 --auto-type

    I have my keypass2 open as a window.
    I have a test entry entitled 'pluma' with a test username and password.
    I have tried using the global auto-key in a new pluma window and nothing happens.
    Going to keepass and pressing cntrl-v does work but I really want to get the global auto-key to work.

    With a pluma window open as 'Unsaved Document 1 - pluma', I have also tried setting it as a target window.
    The target window drop down includes the window title exactly as above and I have set that. Still nothing.

    It isn't the set-up of the hotkey itself as 'mono /usr/lib/keepass2/KeePass.exe' (without '--auto-type') will happily open a new keepass instance. When I add '--auto-type', I get nothing.

    I figure it must be something to do with not matching the window titles.

    Any help would be great.

     
    Last edit: rob-sp 2013-08-12
  • Marko Schulz

    Marko Schulz - 2013-08-25

    Hello,
    about 1 month ago I've installed keepass2 for natty (11.04) via ppa:jtaylor/keepass. I know I have an older Ubuntu, but is there still a possibility to download the package keepass2 for natty (amd64) from an archive?

    Thanks & Regads
    Marko

     
    • David Lechner

      David Lechner - 2013-08-26

      No. Since 11.04 is no longer supported, I don't think anyone is going to maintain a package for it in a PPA. You can however download one of the .deb files from here. You should be able to manually install as I don't think any of the dependencies have changed in quite some time.

       
  • Pascal Fournier

    Pascal Fournier - 2013-12-16

    @rob-sp I'm running ubuntu 12.04. I used to have the same problem: ctrl-V OK but auto-type with ctrl+alt+A KO (tried keepass 2.18 from synaptic and keepass 2.24 portable). My problem was that I was too slow to type the keys! I don't know if it can be tuned but to make it work you need to type the keys very fast! I find it easier with both hands! I don't have this problem on windows. Another solution would be to stick to a 2-key combination instead of 3-key one.
    Also I would advise using the portable version instead of the "KeePass 2.x for Debian/Ubuntu Linux" (i don't know about the jtaylor version). I have some display issues on the "KeePass 2.x for Debian/Ubuntu Linux" (text field truncated, caracters typed displayed twice). Those issues are not present in the portable version.
    Hope that helps!

     
  • Pascal Fournier

    Pascal Fournier - 2013-12-18

    I thought I had it figured yesterday but again today i'm having troubles with the shortcuts! sometimes it works, sometimes not, it's hard to find the proper timing! I have found another way though: the shortcuts are more responsive when configured through compizConfig settings manager: run ccsm then search for commands...

     
  • Radar Hill

    Radar Hill - 2014-10-17

    Is the package being automatically updated to keep pace with the core project updates? Keepass has been at v2.28 for about a week but the package is still at 2.27.

     
  • Paul

    Paul - 2014-10-18

    The update process is manual.
    You can update by copying the files from the portable KeePass package over the top of your existing files - after a backup, of course.

    cheers, Paul

     
<< < 1 2 3 4 > >> (Page 3 of 4)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks