introducing debian/ubuntu keepass2 package

<< < 1 2 3 4 > >> (Page 2 of 4)
  • Peter Matthews

    Peter Matthews - 2011-06-10

    Worked for me - thanks!

  • Tom Howe

    Tom Howe - 2011-06-18

    I have a newly installed lucid lynx (netbook version) and the sudo apt-get update fails on a 404 for this

    Checking the site reveals has a maveric and natty, but no lucid.
    Is there something else I can try?

  • Tom Howe

    Tom Howe - 2011-06-18

    About lucid lynx, I just saw t-monster's work around.  I got to Synaptic, but could not find any "other software".  I'm a bit of a novice, that.  How do I find it?

  • Chris Currier

    Chris Currier - 2011-06-22

    Thanks t-monster for the tip - worked fine. pipertom, the edit may be made under System/administration then Software Sources. In Other Software. look for '' highlight then click the edit button. Change Distribution from lucid to maverick. Close software sources. In terminal do an update 'sudo apt-get update', then Synaptic should show two versions of keepass - select keepass2. Synaptic does have a link to software sources under settings, repositories (FYI). Enjoy lynx….

  • Hunter

    Hunter - 2011-06-22

    Is it possible to have portable version of keepass for ubuntu?

  • skymarshal

    skymarshal - 2011-06-28

    Thanks t-monster, that worked for me too on Ubuntu Netbook Edition 10.04.

    Only problem is that the keepass2-docs package won't install without uninstalling keepass2.  Anyone know why that might be?

  • Julian Taylor

    Julian Taylor - 2011-06-28

    I made a small mistake in the ppa version. Should be fixed in version ~ppa2

  • Flokass

    Flokass - 2011-08-10

    Anyone can help me how to change the KeePass tray icon?

  • Slava Fomin

    Slava Fomin - 2011-09-07

    Thanks for this great app! I've been using it on Windows for quite some time and now moved to Linux.

    But i have some issues with it running under Debian and Xubuntu.

    I can't paste "copied" values from KeePass, not in other aps, not event inside KeePass itself -- any ideas?

    It works for some time after reboot, but then it just stops.

  • Slava Fomin

    Slava Fomin - 2011-09-12

    I've reinstalled it from PPA and now i can't copy anything from KeePass. Please advise!

  • Sunil Kim

    Sunil Kim - 2011-10-12

    Would this work with mono 2.10? It doesn't seem working..

  • Julian Taylor

    Julian Taylor - 2011-10-12

    can you give more details?
    Its running fine for me with mono 2.10 in ubuntu oneiric an debian experimental

  • Lord Melkor

    Lord Melkor - 2011-11-10


    I'm currently still using Ubuntu Maverick Meerkat 10.10 but testing on a Natty Narwhal 11.04 did the same thing.

    There's a big issue with KeePass but I suspect more a problem with Mono (or the way KeePass uses it through .NET calls maybe).

    Using KeePass in general is no problem but the app crashes very often everytime I use a GLOBAL (system wide) shortcut to trigger an external action. For example, I use Parcellite clipboard manager to have a clipboard history and it uses a global shortcut to make the popmenu appear. I also have many other global keyboard shortcuts to launch apps.

    When I handle KeePass (view database, adding/modifying entries, …) it oftenly crashes if I invoke global external shortcuts ! It just vanishes with no warning. It's not everytime but very often nonetheless.

    Curiously, there's never a crash when the global shortcut involves a very high priority level shortcut such as Alt+Tab and WindowManager related shortcuts (minimize, rollup, …) including Compiz plugins (PlaceWindow, etc.). Maybe this is because those shortcuts are intercepted by the WindowManager and never reach the application level dispatcher.

    I invoke the clipboard manager more often than any other shortcut so I get many KeePass crashes. Another interesting thing to note : If I REMOVE the focus from KeePass window (main or edit entry) by activating desktop background or selecting another app window, invoking any shortcut doesn't make KeePass crash and that's the way I do currently to avoid the crashes.

    Anyone experienced the same ?

  • Larry3406

    Larry3406 - 2011-11-22

    for jtaylor108,
    a package is basically included in the latest Debian Squeeze, but its name is keepassx and not keepass2.
    That makes difference !

  • Anonymous - 2012-02-02

    Thanks for 2.18 version in PPA

  • Brutal1s

    Brutal1s - 2012-02-12

    I have installed this, but how can I get the tray icon to work? It doesn't display an icon at all, just a grey/white background. And I don't see the icon in the unity side panel. I have this installed on 11.10.

  • Julian Taylor

    Julian Taylor - 2012-02-12

    the icon is an issue with unity in combination with WinForms used by keepass. There are only 3 winform applications in ubuntu so the incentive of the unity developers to fix this bug is low, patches are welcome though.

    Its similar for the taskbar, unity uses appindicators which is different from the old way and is not supported by mono winforms.

  • Sergey

    Sergey - 2012-04-01

    Hello! Keepass release for Ubuntu 12.04 Is planned?

  • Tranas

    Tranas - 2012-04-01

    Maybe I am missing the point here. In Ubuntu 11.10 Keepass autotype does not work properly, copy and paste does not work properly -  but the claim is that MONO is broken - but MONO is not even part of 12.04, Cannonical has evidently had enough, but Keepass is still offing the bugs on MONO.  Looks like a classic cluster****. YMMV

  • Julian Taylor

    Julian Taylor - 2012-04-01

    of course mono will still be a part of 12.04, it just not installed by default anymore.
    12.04 will have 2.18 packaged.

  • bdd2112

    bdd2112 - 2012-04-09

    I would agree it is a Mono 2.10 issue.  I am running keepass 2.16 and recently accepted the Mono 2.10 update for Ubuntu 10.04 and I lost the cut and paste capabilities.  I'm planning on reverting to the previous version of Mono to regain cut and paste.

  • bdd2112

    bdd2112 - 2012-05-04

    I decided not to try downgrading Mono.

    Since I am also using KeePassDroid, I converted my 2.x database to 1.x and am now using KeePassX.

    Copy and paste works again, so if you don't use any of the features in 2.x databases, I recommend converting your DB to 1.x and using KeePassX if you run Linux instead of Windows.

  • Torsten Skadell

    Torsten Skadell - 2012-05-22

    What is the difference between the KeePass.exe from your deb-package and the KeePass.exe of the official zip-package?
    And how can I check the integrity (e.g. OpenPGP) of your deb-package?

  • Julian Taylor

    Julian Taylor - 2012-05-22

    there is not much difference.
    The advantage of the package is dependency handling and desktop integration (launchers, mime types etc)

    unfortunately you can't simply verify the integrity with openpgp as the source is only provided in zip form and must be repacked to gzipped tar format. I of course verify the signatures and try to review the source before each upload
    Besides removing of some binary files the source package is almost identical to the zip.
    There are a few patches applied to compile with mono and integration. see apt-get source keepass2 and in there the debian/patches folder

    The package source is in git:;a=summary

  • montego

    montego - 2012-06-26

    For those of you who experienced cut-and-paste issues, I found the issue was only with pasting into Chrome.  All other applications I used the paste worked just fine.

<< < 1 2 3 4 > >> (Page 2 of 4)

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks