introducing debian/ubuntu keepass2 package

2011-04-25
5 days ago
1 2 3 4 > >> (Page 1 of 4)
  • Julian Taylor

    Julian Taylor - 2011-04-25

    Hi,
    a package for keepass2 was recently uploaded into the debian archives.
    http://packages.debian.org/sid/keepass2

    This makes it easier for you to install keepass and all its dependencies under mono and integrates it with the standard freedesktop.
    It is currently in unstable and will migrate to testing in a few days.

    It is not included in ubuntu yet. It will be in the main archives in the over next version 11.01 (oneric)
    To accommodate 11.04 and 10.10 users I have set up a ppa:
    https://launchpad.net/~jtaylor/+archive/keepass

    to use it type into a terminal:
    sudo apt-add-repository ppa:jtaylor/keepass
    sudo apt-get update
    sudo apt-get install keepass2

    KeePass language files (*.lngx) should be placed in $XDG_DATA_HOME/KeePass
    If $XDG_DATA_HOME is not set it defaults to $HOME/.local/share

    The XSL transformation style sheets for exporting databases and the documentation are
    installed in /usr/share/keepass2/

    known issues:
    Multiple instances of KeePass are disabled as the communication between
    them is broken on unix systems (will be fixed next release).

    The KeePass plugins are untested and may not work correctly.
    They currently have to be placed in into /usr/lib/keepass2/
    but this is not recommended as files in that location may be overwritten by package upgrades in future.

    Please report bugs related to the package to the debian or ubuntu bug trackers and not to this site here.

     
    • Julio Maranhao

      Julio Maranhao - 2016-06-24

      I have a fresh Ubuntu 16.04 LTS installation on my old pc (2008). Before I was using Win7.

      I installed keepass2 from yakkety but all dependencies from xenial (xdotool also). This means I am running keepass2 2.33+dfsg-1, the same version from J. Taylor's ppa. Actually it's all from JT (thank you).

      Firefox and Chrome are using extensions just to put the visited url in the title and I've configured a custom shortcut (Ctrl+Alt+A) for global auto-type as documented. It works very well!

      What is not working is:

      1) Some keepass2 shortcuts are messed. Ctrl+C does Ctrl+V, Ctrl+V does Ctrl+B, Ctrl+B does Ctrl+N. It seems like a shift. But Ctrl+F is ok. I only tested those ones.
      2) I have an yubikey configured with a static passphrase. When I use it, some letters are Shifted (in the Shift key sense). So a password abcd1 may be put in the keepass2 open dialog as abCd1, ABcd1, abcd!, or even abcd1.

      Of course the chances are this behavior is from mono/ubuntu. But as no one complained already, I do. Do someone have these issues? Or am I alone?

      Cheers.

      P.S.: These issues are just annoying. keepass2 IS usable in ubuntu. Thank you.

       
      • Paul

        Paul - 2016-06-25

        As the Yubikey also does it there seems to be some odd Keyboard behaviour from Ubuntu/mono. Does Auto-Type from KeePass work?

        cheers, Paul

        p.s. This reply is really burried, a new thread, or a response at the end of the thread would have been easier to find.

         
      • Humberto

        Humberto - 2016-10-12

        Hi @Julio Maranhao.

        I'm using this setup of keepass2 in two machines, one Ubuntu 16.04 and a Linux Mint 18 Sarah. Neither show the keyboard fuzzyness you are describing. I also use it in a daily basis, with xdotool, since many years ago. I don't own a yubikey, so I cannot compare the second point.
        Also, I'm adding the keyfox plugin to test (would like to confirm if that's the one you are reffering to), but I feel like I never needed such plugin. Give me a few days to test about it and compare.

        Just a happy keepass2 user on GNU/win environtents.

        Cheers.

         
    • doc2k

      doc2k - 2016-07-23

      hi,

      there was an malware-alert on actual 2.34-version of /usr/lib/keepass2/KeePass.exe during a system-scan with several antivirus-scanners today.

      checked hashsums of the .exe installed via ppa and the .exe in KeePass-2.34.zip from keepass.info - they are different:

      MD5
      bad19f7edc9e5fcc4ed244c045f05fdf  keepass2_2.34+dfsg-1~ubuntu16.04~ppa1_all.deb/data/usr/lib/keepass2/KeePass.exe
      b023de11916c2b9048fc01b0afe0ef66  KeePass-2.34.zip/KeePass.exe
      
      SHA256
      6fb2a0be85de987fdd11fc89bc0a3661cce3e110211a7a365c3b76ddf9c60203  keepass2_2.34+dfsg-1~ubuntu16.04~ppa1_all.deb/data/usr/lib/keepass2/KeePass.exe
      a6e929cf62d9ce3a7e1909b64829a678c60bc94fad4fdaa0178d28fc932f722b  KeePass-2.34.zip/KeePass.exe
      

      here is, what virustotal analysis for both files:

      keepass2_2.34+dfsg-1~ubuntu16.04~ppa1_all.deb/data/usr/lib/keepass2/KeePass.exe: https://www.virustotal.com/de/file/6fb2a0be85de987fdd11fc89bc0a3661cce3e110211a7a365c3b76ddf9c60203/analysis/

      KeePass-2.34.zip/KeePass.exe: https://www.virustotal.com/de/file/a6e929cf62d9ce3a7e1909b64829a678c60bc94fad4fdaa0178d28fc932f722b/analysis/

      so, i'm doubtful if the false-positive argument, given in the threads on on launchpad.net and linuxmintusers.de could be the reason...

      shouldn't the exe-files, installed by ppa and shipped by zip-file identical?
      causes the difference due to necessary modifications made by ppa-maintainer Julian?
      are other reasons thinkable, like an injection of malware in the ppa-files, like happend with the iso-files of linuxmint-distribution after hack of linuxmint-website in february 2016?

      as a precaution, i switched to keepassx until i can reproduce these alarm messages as harmless.

      greets

      it possible, that ppa-files afe

       
      • Paul

        Paul - 2016-07-23

        Why not use the KeePass files from the zip?

        cheers, Paul

         
      • David Lechner

        David Lechner - 2016-07-23

        Debian/Ubuntu packages are always built from source code. The .exe in the debian package is build using the mono compiler on Linux whereas the the .exe in the official KeePass .zip file was built with the .NET compiler on Windows. So, it is not suprising at all that the .exe files would be different.

        I suppose that it is possible that the launchpad build service could be hacked, but you would think someone would have caught on by now and made some sort of official announcment and shut it down until it was fixed.

         
        • T. Bug Reporter

          T. Bug Reporter - 2016-07-23

          it is not suprising at all that the .exe files would be different.

          Then it is (or should be) the responsibility of the package maintainers for those versions to publish the correct hashes for their output files - and to make it clear that the hashes published on keepass.info do not apply to those packages.

           
  • Denis Chistyakov

    Great news thnx. Tested on Ubuntu 10.10 all ok.

     
  • Sebastian Schuberth

    Thanks a lot! It's also working nicely here on Kubuntu 10.10 64-bit.

     
  • ubuntuser7823

    ubuntuser7823 - 2011-04-28

    This is excellent! Works great on the latest version of Ubuntu (11.04 64-bit). Thank you Keepass!! Saved my life

     
  • Christopher Manning

    Excellent, an official ubuntu package is very much appreciated.

    Please add links for where to submit bugs, I couldn't find where to submit a bug based on the information you originally provided.

    I am getting the error "The requested feature is not implemented" when trying to open a database from an FTP url.

     
  • Julian Taylor

    Julian Taylor - 2011-04-30

    its probably not synced to all mirrors yet, give it a bit more time.

     
  • Anonymous - 2011-05-05

    Glad to see one of my favorite programs comes to my favorite OS. Hope to see interesting integrations like gnome applets and even to start to use the gnome keyring http://live.gnome.org/GnomeKeyring ;)

     
  • Rick

    Rick - 2011-05-19

    Note the following command might not work:
    sudo apt-add-repository ppa:jtaylor/keepass

    Instead try:
    sudo add-apt-repository ppa:jtaylor/keepass
    (note the add and apt flip)

    If still not work, try:
    sudo apt-get install python-software-properties

    Then one of the apt-add or add-apt commands as described here and in original instructions

     
  • Vassilis Trigkas

    Does it works in ubuntu 10.04 LTS?

     
  • Julian Taylor

    Julian Taylor - 2011-05-27

    keepass only supports mono >= 2.6 which is not available in 10.04.
    There is the badgerports ppa which provides 2.6 for 10.04:
    http://badgerports.org/

    you should be able to use the the >= 10.10 keepass packages with the mono version from badgerports.
    You can download the packages here:
    https://launchpad.net/~jtaylor/+archive/keepass/+packages
    but it may not work.

     
  • T-Monster

    T-Monster - 2011-06-03

    Just to confirm that I have KeePass running on 10.04 LTS (Lucid)

    I already had Badger Ports in my repository list, so (from the previous post) I'm presuming that helped :¬)

    I noticed that the repository only has "maverick" and "natty" dists setup, so I just opened Synaptic, opened the "Other Software" in the repositories, found keepass and edited the distribution field from "lucid" -> "maverick"

    Returning to Synaptic, I reloaded the package info and it all worked - along with a few dependancies it knew it needed.

    Great work! Thanks!

    I'm not saying that's the best way of getting the problem solved, but it worked for me :¬)

     
  • Shalbatana

    Shalbatana - 2011-06-06

    running 11.04 Ubuntu on a eeepc 900 series, and the database is on a USB key. package works just fine.

    One note:
    1) The installer didn't create a program icon, rather I still have to right-click on the database and select "open with keepass". This is fine, but I wanted to let everyone know in case they're a Linux newb like me and have no idea what to do.

    Thank you so much for this. It was such a hassle for us linux primatives to figure out what to do previously. Last time I ended up getting it working, but I know I installed way too many mono packages, etc. that I didn't need. I was half way through doing it again when I found this thread with the good news.

    This program is a godsend, especially since I regularly work on Windows and Mac, and have Linux on the laptop.

     
  • Anthony Blond

    Anthony Blond - 2011-06-09

    Tested under Ubuntu 11.04 AMD64, works.
    Similar issue to Shalbatana: No icon when added to main launcher menu. Will have to add manually.
    Brilliant program. Been using it under Windows for a while, when I switched to linux on laptop couldn't access the version 2 database, so had to install keepass2 via wine. This new version is awesome. Just donated what I could afford.

     
  • Peter Matthews

    Peter Matthews - 2011-06-10

    I installed KeePass2 into Ubuntu  following the instructions, with no problems. However the result is of no use to me. I have Ubuntu on my travelling netbook, and XP SP3 on my desktop - which runs KeePass 1.x. There seems to be no way of getting the desktops 1.x kdb file read into Ubuntu. Or, hopefully, I am wrong???

     
  • Julian Taylor

    Julian Taylor - 2011-06-10

    the keepass2 package does not include the keepass 1 import libraries.
    But keepassx, which is compatible with keepass 1, is also packaged in ubuntu/debian.

     
1 2 3 4 > >> (Page 1 of 4)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks