Automatically sync with open file when it changes

2013-10-09
2013-10-14
  • Rune Jacobsen

    Rune Jacobsen - 2013-10-09

    This might have been requested many times before, but I couldn't easily find it.

    I'm one of those guys who stores my .kdbx on DropBox. Yeah, security. But there it is.

    I use KeePass 2.2x on ~3 computers, and I would love for it to automatically sync with the open file if it changes while KeePass is running.

    Either an option to enable this directly, or the possibility to set this up using a trigger.

    Would something like this be possible?

    Thanks!

     
  • Paul

    Paul - 2013-10-09

    Dropbox may have lax security, but KeePass doesn't. Just make sure you have a long complex password and use many encryption rounds.

    A trigger is currently the only option. There is an example Dropbox trigger here: http://keepass.info/help/kb/trigger_examples.html#dbsync
    You will need to add a trigger to save the database after every modification, or after you save manually, which will probably be much better because there isn't a "database modified" trigger - "user interface state updated" is closest.

    cheers, Paul

     
  • Rune Jacobsen

    Rune Jacobsen - 2013-10-09

    Hi Paul,

    Thanks for your reply. Yeah, that is pretty much why I'm not too worried about storing the file on DropBox. :)

    I'll look into that recipe for doing it. It would of course still be a lot easier to just click a checkbox in the options somewhere, but I'm very happy that it can be done - just goes to show what a lovely, flexible piece of software KeePass really is. :)

    Thanks again!

     
  • Will R

    Will R - 2013-10-14

    You can do it with triggers easily - just set one up which automatically synchronizes with the database in your dropbox folder on database open and on database close. That way you always have the latest copy, and no risk of corrupting your DBs.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks