Incompatible on Linux?

  • sticke4

    sticke4 - 2010-01-31

    Hi I am running KeePass version 2.09 on Ubuntu 9.10 Karmic Koala and I am using Mono version (Linux implementation of .Net framework). I put the plgx file in the directory of the executable but it returns the following error when I start KeePass:

    The following plugin is incompatible with the current KeePass version: /path/to/plugin/KeePassFaviconDownloader.plgx
    Have a look at the plugin's website for an appropriate version

    KeePass' main features work normally using Mono on Ubuntu, except features like "check for updates" which it outputs that "The .Net framework/runtime, under which KeePass is currently running, does not support this operation."

    Could it be that the plugin is not working because Mono doesn't support it? Is there any work-around? I really like this plugin and use it on my Windows Box, but it would be awesome if it could work on my Linux computer.

  • Luckyrat

    Luckyrat - 2010-01-31

    Yes, there must be something that Mono does not support correctly but maybe we can find a way to work around it. Can you try some other plugins in the plgx format?

    Also, could you try adding "-debug" to the KeePass command line and see if that provides any more detail about why the plugin is not compatible?


  • sticke4

    sticke4 - 2010-02-08

    Sorry for the late reply, I have been a little busy.

    I wasn't able to get the data because my Linux laptop isn't working right now. So once I found out the reason why it isn't working and eventually fix it, I will post back with the info you wanted.

  • saarworres

    saarworres - 2010-02-23

    I have the same problem. The -debug command change the warning to: "Operation is not valid due the current state of the object". I hope this helps a little.

  • Luckyrat

    Luckyrat - 2010-05-18

    I have no "proper" fix for this yet but just wanted to say that I've since seen the debug message "Operation is not valid due the current state of the object" shown when KeePass is unable to compile the plugin correctly. I suspect that either the Mono compiler doesn't work in quite the same way as the Microsoft one or that KeePass just needs to modify what it asks Mono to do.

    First things first, does KeePass 2.10 with the latest version of Mono (2.6) fix this problem?

    If not, maybe try installing the plugin on a Windows machine, navigate to the KeePass plugin cache directory and copy the resulting DLLs into the plugin cache on Linux (not sure of the specific location but if you can get another plugin to compile then you should be able to work it out).


  • Bob Bell

    Bob Bell - 2011-03-30

    I can reproduce this problem with Mono v2.6.7 and KeePass v2.14

  • Luckyrat

    Luckyrat - 2011-03-31

    I've just tested this with the latest build of KeePass and it seems to work fine (it downloaded at least one icon anyway). This build will be released as KeePass 2.15, although I don't know when. So please try again once you can download and use KeePass 2.15 from

    I only have Mono 2.10 to test with so if there are still problems with 2.6 please let me know in case there's something I can change to get it to work properly.


  • Bob Bell

    Bob Bell - 2011-04-03

    I'm running Ubuntu 10.10, and Mono 2.6.7.  I'd be happy to try the latest once it is available.  If you like to send me a build prior to the release, I can test that, too.

  • Luckyrat

    Luckyrat - 2011-04-03

    Thanks for the offer bbell but it's a KeePass update that's required so it's not up to me when it or any test builds are released. Just keep an eye on for when 2.15 is released and then please let us know if it works for you then.


  • aeilos

    aeilos - 2011-04-18

    Works with Keepass 2.15 on Ubuntu 10.10 and mono 2.67 - Thanks!

  • Bob Bell

    Bob Bell - 2011-04-18

    It does seem to be generally working.  Thanks!  I've having a specific problem with a few sites, but I'll post about them separately.  It general, it works now.

  • ZyMOS

    ZyMOS - 2013-10-23

    I am having the same problem. I use mono-2.10.9 keepass-2.22 on 64-bit gentoo Linux. I had the same problem with keefox, but if i include the exe's along with the plgx, it worked. I don't know if this helps.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks