Plugin is incompatible with latest KeePass version

Help
rukimira
2014-04-08
2015-01-26
  • rukimira

    rukimira - 2014-04-08

    Hi, after updating KeePass to version 2.25, the plugin won't load at startup: "The following plugin is incompatible with the current KeePass version".
    Could you fix this?

     
  • rukimira

    rukimira - 2014-04-13

    Upgrading to KeePass 2.26 solved the issue. The culprit seemed to be KeePass and not the plugin... Sorry for the false alarm!

     
  • Martin

    Martin - 2014-04-29

    Hi ! I am running 2.26 on ubuntu 14.04 and the plugin doesn't work. Any idea ?

     
  • Alan Jump

    Alan Jump - 2014-10-23

    No joy on 2.28 under Ubuntu 14.04.

     
  • atomicdecay

    atomicdecay - 2014-10-24

    Latest version IS working with 2.28 on Windows 7, if that helps narrow things down.

     
  • machredsch

    machredsch - 2014-11-11

    Latest version doesn't work with 2.28 (and mono 3.2.8) under Gentoo, too.

    Edit: It works. Had set wrong rights to the file under /usr/lib/Keepass. Instead of rw-r-----, I set it to +r for world (rw-r--r--) and now it works, sorry.

     
    Last edit: machredsch 2014-12-22
  • joh6nn

    joh6nn - 2015-01-10

    i'm using ubuntu 14.04, keepass 2.28, mono 3.2.8, and perms on the plugin are -rw-r--r-- . i get two different error messages:

    • SendFailure: Error getting response stream (Write: The authentication or decryption has failed.): SendFailure: (https urls only)
    • A null reference or invalid value was found [GDI+ status: InvalidParameter].

    i was able to successfully download an icon for gravatar.com, and one other site, but all other entries failed.

     
  • Nixblicker

    Nixblicker - 2015-01-13

    Also using ubuntu 14.04 and keepass version 2.28 and get the same complaints about plugin incompatibility as with version 2.25. Permissions are set to -rw-r--r--, but still no love. I wonder what makes it run on some setups (machredsch&rukimira) and not on others. Is it possible, that mono is the culprit?

    Any ideas how to proceed?

     
  • Luckyrat

    Luckyrat - 2015-01-13

    Mono is certainly a possible culprit.

    AppArmor / SELinux might cause problems too. No idea how or why but given that changing permissions has fixed KeePass compilation errors before, I'd not be amazed if those protections cause Mono or KeePass problems.

    Try running KeePass with --debug and --saveplgxcr in case it reveals any more detail about the problem.

     
    • Nixblicker

      Nixblicker - 2015-01-15

      Thanks for following and for the hints luckyrat.

      If I apply the suggested arguments, there is a more detailed, but unfortunately not very intelligible feedback (at least for me, that is) from keepass regarding the plugin. Unfortunately it doesn't let me copy&paste it in here, so I attached an image of the error window.

      Hope this might be leading to something...

      Cheers,
      Nix

       
  • Luckyrat

    Luckyrat - 2015-01-15

    Have you definitely got the full version of mono installed? (I think it's called "mono-complete" in the repos)

     
  • Nixblicker

    Nixblicker - 2015-01-24

    Sorry for being that late, Luckyrat, I was/am struck by a nasty flue.

    No, certainly not. Is that a prerequisite to install this plugin? Well, isn't that a somewhat unnecessary overhead? Installing mono-complete would download 168 packages and take up about 115MB more on my low-end system.

    I think I prefer to live without the favicons plugin then.
    Nevertheless, thanks for your great support!

     
  • Luckyrat

    Luckyrat - 2015-01-24

    Both KeePass and their plugins are written on the assumption that all the .NET libraries are available as per Windows. Things would be expected to break on any system without the complete set of libraries.

    That said, it is highly likely that only a small number of libraries are required for any specific plugin (I presume those 168 packages are all separate .NET libraries?)

    In particular, take a look for mono-dmcs which should enable the basic plugin functionality in KeePass.

    If KeePass Favicon downloader still doesn't work but other plugins do, there must be other missing packages. You might be able to work out what they are by inspecting the file outputted by KeePass if you execute it with the --saveplgxcr command line option.

    Obviously just installing mono-complete is much easier than this and means you won't have to repeat a similar process for other plugins in future but I understand if you would rather spend some time getting a solution that consumes less disk space.

    As you suggest, you might find living without the plugin on your Linux system is OK provided that you have access to another KeePass installation from time to time - I don't even use the plugin myself on a regular basis, but that's because KeeFox creates all my new entries with favicons already included.

     
  • joh6nn

    joh6nn - 2015-01-26

    Luckyrat, I can confirm i have mono-complete installed, and that i'm still experiencing these errors. There was no file created by using --saveplgxcr, but if you'd like i can attach the STDOUT from using --saveplgxcr and --debug

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks