#158 Compile errors on Debian Sid

open
nobody
None
5
2006-03-09
2006-03-09
Tron
No

Hello all,

I wonder if I'm the only one who wishes to use kdepimpi
on debian sid and is
running into compile troubles. No matter which version
of kdepimpi I try, I get:

addresseeeditorwidget.h:166: error: ISO C++ forbids
declaration of
'QComboBox' with no type
addresseeeditorwidget.h:166: error: expected ';' before
'*' token
../libkdepim/ksyncmanager.h:222: warning: 'class
KSyncInterface' has virtual
functions but non-virtual destructor
../libkdepim/ksyncmanager.h:226: warning: unused
parameter 'manager'
../libkdepim/ksyncmanager.h:226: warning: unused
parameter 'resource'
make[1]: *** [obj/unix/addresseeeditordialog.o] Error 1
make[1]: Leaving directory
/install/kdepim-2.2.7/kaddressbook'
make: *** [sub-kaddressbook] Error 2

Maybe someone knows what might be wrong.

Would it be possible for the developers to compile
static packages for linux
on i386 architecture? Those should run no matter what...

Sincerely,
Tron

Discussion

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks