and how can i know it?

On Mon, Jul 27, 2009 at 8:09 PM, Dan Dennedy <dan@dennedy.org> wrote:
ffmpeg only supports uncompressed via V4L(2). Please lookup what
formats your webcam provides.

2009/7/27 Javier Agustěn Fernŕndez Arroyo <elhoir@gmail.com>:
> hello,
> i dont know if this is the corerct way for reporting problems... but let me
> explain..
>
> i have recently bought a webcam, and it works in videolan, using the
> video4linux 2 setting. The device file is /dev/video0.
>
> But in kdenlive, it shows "broken capture. Please check params"
>
> this is the kdenlive log when i try to capture:
>
> kdenlive(9822) RecMonitor::slotRecord: Capture: Running ffmpeg  "-f
> video4linux2 -s 320x240 -r 15 -i /dev/video0 -qscale 1 -ab 224k -vcodec
> mpeg4 -acodec mp2 -y /home/elhoir/capture0000.mp4 -f mpegts -vcodec mpeg4
> -acodec mp2 -"
> kdenlive(9822) RecMonitor::slotRecord: Capture: Running ffplay  "-f mpegts
> -x 465 -y 124 -"
>
> When running it in the command line, i get this:
>
> elhoir@elhoir-desktop:~$ ffmpeg  -f video4linux2 -s 320x240 -r 15 -i
> /dev/video0 -qscale 1 -ab 224k -vcodec mpeg4 -acodec mp2 -y
> /home/elhoir/capture0000.mp4 -f mpegts -vcodec mpeg4 -acodec mp2 -
> FFmpeg version 0.5-svn17737+3:0.svn20090303-1ubuntu6, Copyright (c)
> 2000-2009 Fabrice Bellard, et al.
>   configuration: --enable-gpl --enable-postproc --enable-swscale
> --enable-x11grab --extra-version=svn17737+3:0.svn20090303-1ubuntu6
> --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-libgsm
> --enable-libschroedinger --enable-libspeex --enable-libtheora
> --enable-libvorbis --enable-pthreads --disable-stripping --disable-vhook
> --enable-libdc1394 --disable-armv5te --disable-armv6 --disable-armv6t2
> --disable-armvfp --disable-neon --disable-altivec --disable-vis
> --enable-shared --disable-static
>   libavutil     49.15. 0 / 49.15. 0
>   libavcodec    52.20. 0 / 52.20. 0
>   libavformat   52.31. 0 / 52.31. 0
>   libavdevice   52. 1. 0 / 52. 1. 0
>   libavfilter    0. 4. 0 /  0. 4. 0
>   libswscale     0. 7. 1 /  0. 7. 1
>   libpostproc   51. 2. 0 / 51. 2. 0
>   built on Apr 10 2009 23:18:41, gcc: 4.3.3
> [video4linux2 @ 0x833fac0][3]Capabilities: 4000001
> [video4linux2 @ 0x833fac0]Cannot find a proper format.
> /dev/video0: I/O error occurred
> Usually that means that input file is truncated and/or corrupted.
> elhoir@elhoir-desktop:~$
>
> Can anyone help me? Many thanks
>
> The params string in kdenlive is this:
>
>  -f video4linux2 -s 320x240 -r 15 -i /dev/video0
>
> Im using Ubuntu 9.04, and kdenlive 0.7.3 (too old?)
>
> ------------------------------------------------------------------------------
>
> _______________________________________________
> Kdenlive-devel mailing list
> Kdenlive-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/kdenlive-devel
>
>



--
+-DRD-+

------------------------------------------------------------------------------
_______________________________________________
Kdenlive-devel mailing list
Kdenlive-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/kdenlive-devel