Problem with qt-libraries?

Help
Futile
2004-06-25
2013-03-07
  • Futile

    Futile - 2004-06-25

    Hi!

    I was trying to run the ordinary ./configure and solved the various dependencie problems but I got stoped short with the following notice;

    ***
    checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found. Please check your installation!
    ***

    I run Xandros OS 2 Pro, thus Debian 3.0 (Woody), kernel 2.4.22-x1 and KDE version 3.1.4

    Does anyone know what i should do? I tried to apt-get install the various qt-packages (found through; http://packages.debian.org/cgi-bin/search_packages.pl?keywords=qt&searchon=names&subword=1&version=stable&release=all )

    I ran configure between every install, but at some libqt3 package, apt threatened to remove all the software i use in KDE, including Xandros special programs.

    I would really appreciate help with this.

     
    • Futile

      Futile - 2004-06-26

      So, I tried again and this time I managed to get the libqt3-emb-dev installed, and the configure went one step further, and stopped with;

      ###
      checking for Qt... configure: error: Qt (>= Qt 3.0) (library qt-mt) not found.
      ###

      No sweat, I thought, and ran; "apt-get install libqt3-mt"

      This was obviously the package that caused me some concern the other day. apt told me;

      ###
      The following packages will be REMOVED:
        [...]LOTS OF PROGRAMS[...]

      The following NEW packages will be installed:
        libqt3 libqt3-mt
      0 upgraded, 2 newly installed, 115 to remove and 10 not upgraded.
      Need to get 5446kB of archives.
      After unpacking 139MB disk space will be freed.
      Do you want to continue? [Y/n]
      ###

      Well, this is obviously not a way to go for me. Is there any way to do without the mentioned package?

       
    • Witold Krakowski

      Got the same problem on a gentoo. I emerged latest Qt libraries, but still get the message about Qt Qt (>= Qt 3.0) not found..What's going on?

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks