problem to sync MBP and iphone

Help
Chatweasle
2010-05-23
2013-04-14
  • Chatweasle

    Chatweasle - 2010-05-23

    Hi there. Glad to have found karatasi at last but no way to get my files from my MacBook Pro onto the iphone 3G. I have read and tried the HELP pages but to no avail. Don't unterstand which information to fill in where. Please help!

     
  • Christa Runge

    Christa Runge - 2010-05-23

    Hi chatweasle,

    did you download the karatasi Java application?

    In the Java application, use the menu File > Settings to configure
    a) Network Settings: synch server network port. Use any IP port which is not used for another application.
    b) Authorized device: use any name for your device, and choose a password.

    At the iPhone, launch the Settings application, then scroll down and choose the karatasi section.
    a) Protocol: select karatasi Java (this is the default)
    b) Host: this is very important. Use the name of your MacBook Pro with the karatasi Java application in your network.
    Alternatively, use the IP address of the Mac.
    Note: you can find out the IP address by using the command line
    ifconfig
    on the shell. (On Windows PC use ipconfig instead).
    The IP address consists of four numbers, separated by a dot; it looks similar to 192.168.22.76
    c) Port: use the same port as you have configured in the Java application.
    d) Device Name, Password: use the same settings as in the Java application.

    After you have setup both applications, press the Synch Server 'Start' button in the Java application. The server status indicator should now turn yellow and indicate 'Server Idle'.
    At the iPhone launch the karatasi application, then press the 'Synch' icon (it looks like a crooked arrow).

    Now it should get a connection. If not, check again your settings, and check if any firewall is blocking the connection.

    Please check also our manual pages on this:
    http://karatasi.sourceforge.net/manual_java/en/overview.html
    http://karatasi.sourceforge.net/manual/en/preferences.html
    http://karatasi.sourceforge.net/manual/en/db_sync_list_view.html

    Christa

     
  • Chatweasle

    Chatweasle - 2010-05-23

    Great. It now works. All I needed to insert was my Mac's IP. Thanks a lot ;-)

     
  • Chatweasle

    Chatweasle - 2010-05-23

    Hi Christa. Sorry; one more little thing: the program now shows me the same amount of vocabulary to test as to learn (I have the German edition that says "Test" and "Üben". How do I reset to start learning all over again? My Italian file e.g. has nearly 20.000 words! I cannot learn them in one day. :-o

     
  • Christa Runge

    Christa Runge - 2010-05-23

    Hi chatweasle,

    can you please give more details?
    Which Java version are you using?
    Which kind of import are you using: csv formatted file, or Palm database?

    Christa

     
  • Chatweasle

    Chatweasle - 2010-05-23

    Hi Christa.

    Java version is 0.2.1. (svn2300 04/2010). I have already imported all the three files I have from the Palm database format. No problems there although it did take some time, due to the sheer number of vocabulary, especially in the Italian file.

    Synching with the iphone now works, too. However, on the iphone, when actually learning, the program thinks that I want to learn ALL the words in each file, which is a problem with e.g. 20.000 words in one file.

    How can I reset this, so I can just take the amount of words from the pool that I want to learn rather than having to deal with the complete pool of words?
    Hope that helps.
    Stefan

     
  • Christa Runge

    Christa Runge - 2010-05-23

    Hi Stefan,

    unfortunately, this Java version 0.2.1 has a bug and adds all committed cards to the drill list during the import of the Palm database.
    However, we are planning another release with a bugfix for this issue very soon.

    We recommend to wait for this release and then repeat the import of the databases.

    Regards,

    Christa

     
  • Chatweasle

    Chatweasle - 2010-05-24

    My bad luck! :-(

    I'll be waiting then. Thanks for the good work so far.

    Regards,

    Stefan

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks