Hi, anybody tried to run spring from jython and experience the same problem?

I tried to put all the needed spring jars to sys.path and loaded all spring classes successfully.
The problem comes when it read the configuration, because I was using namespace based configuration (from spring-tx.jar in the spring 2.5.6 stack).
The error message:
org.springframework.beans.factory.parsing.BeanDefinitionParsingException: org.springframework.beans.factory.parsing.BeanDefinitionParsingException: Configuration problem: Unable to locate Spring NamespaceHandler for XML schema namespace [http://www.springframework.org/schema/tx]
Offending resource: file [c:\myproject\src\main\resources\applicationContext.xml]

I know this is because, I added the namespace on top of the XML file:
--- code fragment --
<?xml version="1.0" encoding="UTF-8" ?>
<beans xmlns="http://www.springframework.org/schema/beans"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:aop="http://www.springframework.org/schema/aop"
xmlns:tx="http://www.springframework.org/schema/tx"
xsi:schemaLocation="
http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans-2.5.xsd
http://www.springframework.org/schema/tx http://www.springframework.org/schema/tx/spring-tx-2.5.xsd">
--- /code fragment ---

Regards,
Daniel
--
Daniel Baktiar
Senior JEE* Monkey -- willing to work hard in the Java beans brewery for a big bunch of bananas (http://dbaktiar.wordpress.com)