I've made a JAR (bean) that acts as a component inside of Fusion 4.0.  Fusion runs a JVM and then calls my JAR when it is needed.  I recently added Jython to my bean.  As a test I tried instantiating a new instance of PythonInterpreter when my JAR's activation method is called by Fusion.  I put some print statements in my JAR and right when I do:
 
PythonInterpreter interp = new PythonInterpreter();
 
my bean semi-hangs (it's supposed to put up a dialog box, all I get is just a small form, about the size of the title bar, with the Java logo and nothing on the client area. It's supposed to be a multi-field Dialog Box).  I look at the Task Manager CPU utilization bar and it's pegged at full utilization.  Now if I close the dialog box "fragment", then the CPU meter drops back to about 0 and I'm back in Fusion, no harm done.  So is this some kind of semaphore/event lock-up?  Anybody have any ideas on how to solve this?  I tried making 'interp' a static field in the class and instantiating it there:
 
public class JythonTestClass {
  
    PythonInterpreter interp = new PythonInterpreter();
...
}
 
but then Fusion wouldn't load my bean at all.
 
thx
 
P.S. - Is it my imagination or has this list been very slow lately?