rpy2/rpy depend on the use of the C extension API. You might have some luck by trying to use Jython 2.7 with JyNI, which supports the C ext API but JyNI is very much still under development: http://www.jyni.org/

In terms of pkg_resources - which is probably a red herring - this is part of setuptools. You should be able to install setuptools directly from PyPI, or you can use my branch which supports the required SSL support with easy_install, https://bitbucket.org/jimbaker/jython-ssl

- Jim

On Mon, Oct 7, 2013 at 8:44 PM, Philip Cannata <phil.cannata@oracle.com> wrote:
I get the following error, any help would be greatly appreciated.

UserWarning: Unsupported Python version. Python (>=2.7 and < 3.0) or
 >=3.3 are thought to be required to run rpy2.
   warnings.warn("Unsupported Python version. Python (>=2.7 and < 3.0)
or >=3.3 are thought to be required to run rpy2.")
Traceback (most recent call last):
   File "tests/ReLrpy2.py", line 1, in <module>
     import rpy2.robjects as robjects
line 15, in <module>
     import rpy2.rinterface as rinterface
line 101, in <module>
     from rpy2.rinterface._rinterface import *
line 7, in <module>
line 3, in __bootstrap__
     import sys, pkg_resources, imp
ImportError: No module named pkg_resources

October Webinars: Code for Performance
Free Intel webinars can help you accelerate application performance.
Explore tips for MPI, OpenMP, advanced profiling, and more. Get the most from
the latest Intel processors and coprocessors. See abstracts and register >
Jython-users mailing list