Just found out why

Eclipse has included ./sandbox/ast/lib/jython.jar in Referenced Libraries, and the removal of the jar fixed the issue.

More info here: http://stackoverflow.com/questions/2674325/eclipse-3-4-ganymede-package-collision-with-type


Cheers

On Thu, May 20, 2010 at 6:01 AM, Oti <ohumbel@gmail.com> wrote:
Anthony

i am using Eclipse 3.5.2 on Windows7 with jdk 1.5.0_22, and Eclipse
3.4.0 on Mac OS X 10.5.8 with JVM 1.5.0.
Both workspaces are checked out from trunk, and i do not see this error message.

best wishes,
Oti.

On Wed, May 19, 2010 at 9:34 PM, Anthony Kong <anthony.hw.kong@gmail.com> wrote:
> Hi, all,
>
> I tried to open jython branch Release_2_5rc4 in Eclipse, and I encountered
> this error message:
>
> Description    Resource    Path    Location    Type
> --------------------------------------------------------------------
> The package org.python.modules.thread collides with a type    thread.java
> /Release_2_5rc4/jython/src/org/python/modules/thread    line 2    Java
> Problem
>
> I wonder if anyone has seen it before
>
> I am using eclipse 3.5.2 + java version "1.6.0_20" on mac osx 10.6.3
>
> Cheers
>
> ------------------------------------------------------------------------------
>
>
> _______________________________________________
> Jython-dev mailing list
> Jython-dev@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/jython-dev
>
>