Well done. I'd forgotten the jarjar thing was going on.

I would add the old ANTLR jars to that list for consideration. (We can't still need 2.7.7, surely?) However, port to the latest is easy to say (http://bugs.jython.org/issue1903).
Jeff Allen
On 23/04/2014 00:50, Jim Baker wrote:
A related point: there are a number of other bugs related to old extlib jars:

http://bugs.jython.org/issue2087 - update Guava
http://bugs.jython.org/issue2092 - update to JLine2
http://bugs.jython.org/issue2110 - update JNR-Posix

There may be others in the bugs db. Once socket-reboot is merged in with beta 3, I'm personally planning to do a comprehensive review of all our extlibs to bring them to their latest version for beta 4. Unless of course we need to do it sooner, as seen in this bug; or someone wants to do it first :).
- Jim

On Tue, Apr 22, 2014 at 3:19 PM, Jim Baker <jbaker@zyasoft.com> wrote:
The underlying problem is an old version of Jar Jar Links, as reported in http://bugs.jython.org/issue2129 and subsequently fixed. I have upgraded Jar Jar Links from 0.7 to 1.4 and pushed the fix to hg.python.org/jython

The reason Jeff didn't see the issue (nor did I) is that we are looking at the regrtest, which uses dist/jython-dev.jar. Frank was instead working against dist/jython.jar, which depends on the Jar Jar Links task to renames classes contained in jars in extlibs to be under org.python in the Java namespace. Once I realized the problem was seen in the difference between running jython-dev.jar and jython.jar (which can be observed with dist/bin/jython --print), the solution was obvious.

- Jim

On Tue, Mar 25, 2014 at 3:19 AM, Jeff Allen <ja.py@farowl.co.uk> wrote:
On 24/03/2014 21:06, fwierzbicki@gmail.com wrote:

On Mon, Mar 24, 2014 at 12:43 PM, Jeff Allen <ja.py@farowl.co.uk> wrote:
That's not a display that means a huge lot to me. jython.java:213 is a first call to PySystemState.getBaseProperties(), so I guess the error is while loading PySystemState?

I ran "ant javatest regrtest" on Windows 7 and on Linux before committing the 1.6 to 1.7 change, with only the usual failures. (Slightly fewer on 1.7.)

Is this just running Jython at the prompt? Say if there's something you'd like me to try on my platforms.

Weird - is it the same if you run "ant clean" first? This problem occurs in the .class files that are generated for each .py file - if they where compiled before with 1.6 you wouldn't see it. If not maybe the JVM on OSX is more sensitive to this. I found the patch from Shashank Bharadwaj - it is here: https://bitbucket.org/shashank/jython-mq/src/tip/fix-asm-via-cfg.patch -- but when I tried to evaluate it back then it had some trouble with doctests that I didn't quite figure out. This may up the priority on getting that patch figured out.


I've usually run ant clean first, and the notes show I did so in this case (on Windows at least, so probably on Linux too). I've been using the Java 7 compiler since about Christmas, only the setting in build.xml has changed. Lately I've been changing the compiler on my path, therefore the one ant uses, between 6 and 7 as I noticed differences in the failures of float-related tests. I haven't seen what you report.

When I'm in Eclipse, it uses a different compiler from the one on my path for Ant, and sometimes I have problems from that, with the exposer, or anonymous classes not found, or when remote debugging. I could try some abusive mixtures, but you seem to have the opposite problem.

Jeff Allen

Learn Graph Databases - Download FREE O'Reilly Book
"Graph Databases" is the definitive new guide to graph databases and their
applications. Written by three acclaimed leaders in the field,
this first edition is now available. Download your free book today!
Jython-dev mailing list