On 24/03/2014 21:06, fwierzbicki@gmail.com wrote:

On Mon, Mar 24, 2014 at 12:43 PM, Jeff Allen <ja.py@farowl.co.uk> wrote:
That's not a display that means a huge lot to me. jython.java:213 is a first call to PySystemState.getBaseProperties(), so I guess the error is while loading PySystemState?

I ran "ant javatest regrtest" on Windows 7 and on Linux before committing the 1.6 to 1.7 change, with only the usual failures. (Slightly fewer on 1.7.)

Is this just running Jython at the prompt? Say if there's something you'd like me to try on my platforms.

Weird - is it the same if you run "ant clean" first? This problem occurs in the .class files that are generated for each .py file - if they where compiled before with 1.6 you wouldn't see it. If not maybe the JVM on OSX is more sensitive to this. I found the patch from Shashank Bharadwaj - it is here: https://bitbucket.org/shashank/jython-mq/src/tip/fix-asm-via-cfg.patch -- but when I tried to evaluate it back then it had some trouble with doctests that I didn't quite figure out. This may up the priority on getting that patch figured out.


I've usually run ant clean first, and the notes show I did so in this case (on Windows at least, so probably on Linux too). I've been using the Java 7 compiler since about Christmas, only the setting in build.xml has changed. Lately I've been changing the compiler on my path, therefore the one ant uses, between 6 and 7 as I noticed differences in the failures of float-related tests. I haven't seen what you report.

When I'm in Eclipse, it uses a different compiler from the one on my path for Ant, and sometimes I have problems from that, with the exposer, or anonymous classes not found, or when remote debugging. I could try some abusive mixtures, but you seem to have the opposite problem.

Jeff Allen