I am having some problems with "Jython" and I am hoping that you can help me to solve them.
I have written a small Jython Applet using your demonstration code as the basis for the code and I have run into a problem.  The code was compiled using the line:
jythonc --deep -- core --jar demo1.jar MyApp.py
This compiles the code with no problem.  I then entered the HTML code following in my webpage
<applet code="MyApp"
When I run the code nothing happens, all that happens is, is that an empty grey box appears on the screen, it has no text on anything else in the box.  Being somewhat familiar with Java Applets I immediately knew something was up.  So I looked for the status bar.  The message in the status bar is as follows: "MyApp class can't be instantiated", I have never seen this error message before.  After that happened I hit the refresh button by accident, and then the text 'G Day' appeared in the Applet.  After that I tried it with your example code in the /demo/example directory on the HelloApplet example and the same thing occurred, it only displayed after hitting the Refresh button. 
The code I used was pretty straight forward:
from java import awt, applet
class MyApp(applet.Applet):
    def paint(self, g):
        g.setFont(awt.Font('Arial', 0, 15))
        g.drawString('G Day', 10, 20)
So my question is this, what am I doing wrong?  Why is the text not being displayed until after I hit the refresh button on the browser.  I know I have done something stupid, but I don't know what it is.
Any help is greatly appreciated.
Thankyou and regards,
Sláinte (Irish for cheers).
Vaughan Egan   ---   celtic@allstate.net.au