undefined symbol!! help!!!

Help
sn4k3
2007-07-19
2013-04-08
  • sn4k3

    sn4k3 - 2007-07-19

    i complied well the libs .lib/.a

    win32 works weel!
    linux no :(

    im doing a css plugin!!!
    plugin error on load:

    undefined symbol: _ZNK6jwsmtp6mailer8responseEv

    my makefile:

    Mail = $(PLUGIN_DIR)/library/jwsmtp/jwsmtp/jwsmtp
    Link = libjwsmtp.a

    ln -sf $(Mail)/.libs/libjwsmtp.a libjwsmtp.a

    without jwsmtp usage my plugin works well! taht erro only happen in linux!

    my file!!!

    #include "library/jwsmtp/jwsmtp/jwsmtp/jwsmtp.h"

    void SU_Mail()
    {
        if (engine->Cmd_Argc() <= 7)
        {
            Msg("Syntax: %s <Smtp Server> <Smtp User> <Smtp Password> <To> <From> <Subject> <\&quot;Mensage\&quot;>\nSMTP: Use \&quot;\&quot; To Igone\n",engine->Cmd_Argv(0));
            return ;
        }
        jwsmtp::mailer mail;

        char *msg = engine->Cmd_Argv(7);
        sprintf(msg, "%s\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\nMail Sended From SourceUtils!\r\nhttp://www.sourceplugins.com/viewtopic.php?t=3875\r\nhttp://forums.alliedmods.net/showthread.php?t=52532",msg);
        mail.setserver(engine->Cmd_Argv(1));
        mail.username(engine->Cmd_Argv(2));
        mail.password(engine->Cmd_Argv(3));
        mail.addrecipient(engine->Cmd_Argv(4));
        mail.setsender(engine->Cmd_Argv(5));
        mail.setsubject(engine->Cmd_Argv(6));
        mail.setmessage(msg);
        mail.operator() ();
        //mail.send();
        //mail.reset();

        if(mail.response( ).substr(0,3) != "250")
        {
            //Msg("SU: Mail Send Error: %s\n",mail.response()); //error
            Msg("SU: Mail Send Error\n"); //error
            return ;
        }
    }
    ConCommand su_mail("su_mail",SU_Mail,"Sends Mails",FCVAR_GAMEDLL);

     
    • sn4k3

      sn4k3 - 2007-07-20

      i fixed that !!!

      i compiled jwsmtp in a linux machine and now .a file works!!

      full working BUT ....

      when i send a mensage server crash/suthdown !!!!

      mensage sent sussfull !!! no errors and server crash after run all void code!!! any edia?

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks