Error in compiling

  • Anonymous - 2002-02-26

    I am getting the same as described by shm i.e I sget Exception while I try to run JWNL.initialize(InputStream):

    How do I avoid this ? I am using java in Debian Linux .


    • Anonymous - 2002-02-27

      Hi, I do not try to solve this problem yet because I have other jobs....:)

      You may notice that NUMBER_OF_VERB_FRAMES is  defined in a .properties file in the <JWNL_PATH>. So, the exception may comes from the jre can not find this file correctly.(I guess...:p,cause I am
      quiet new to Java) I have checked the JDK document and read the Section of ResouceBoudle.My conclusion is this may cause by the dirrerent of locale setting.My locale is zh_TW,and what is yours?

      I will keep tracking on this problem,but I'm not sure when I can solve it.But tracing source codes does help, you could get a try...:)

      Good luck,hope this could help you...

    • Anonymous - 2002-03-11

      Thank you - I was having many of the problems you detail above, and your posts helped tremendously. As to the NUMBER_OF_VERB_FRAMES problem, shm's intuitions are correct, but as the jdk document can be somewhat cryptic, here's what I did:

      (note: I use Win2k. I run visual studio 6 for my own development needs, but because of weird errors I couldn't run an executable through it - I'm running with jre1.4 - which is necessary for Logging stuff)

      The resource files - and/or (not sure which is required) have to be somewhere accessible via your classpath. So, for example, since those files were in the same directory as my jwnl.jar file, when I ran java, the end of my classpath argument looked like this: "...path_to_jwnl/jwnl.jar;path_to_jwnl/"

      The resource files have to be referenced in the properties xml file. The file_properties.xml that comes with the download shows this line:
      <resource class="PrincetonResource"/>

      That's correct - as per the jdk's explanation, the are assumed (.properties is a standard extension and en comes because language is set to english). I added a similar line:

      <resource class="JWNLResource"/>
      just cause it looks like that's where all the important stuff is. But I've only just not had my program break with exceptions (after I solved the resource problem, I had to get jre1.4 so java.util.logging stuff would be found), so we'll see if the wordnet *content* is actually sensible now.

      • Anonymous - 2002-05-06

        Hi...I have solve this problem...-_-...

        The resource decleration should be :

        <resource class="PrincetonResource_en"/>
        <resource class="JWNLResource_en"/>

    • myo sithu

      myo sithu - 2003-07-24

      I have tried all the methods above but still have same error of java.lang.NumberFormatException:NUMBER_OF_VERB_FRAMES...  do I need a system environment variable <JWNL PATH> set like in CLASSPATH?  please help...


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks