a problem for initialization

Help
soda
2004-06-25
2013-04-29
  • soda

    soda - 2004-06-25

    Hi:
    I got this error message (in the bottom) while initializing JWNL.
    It seems not being able to find the dictionary class

    <dictionary class="net.didion.jwnl.dictionary.FileBackedDictionary">
    I have changed the dictionary_path to my wordnet dict directory. (It seems that no matter which path I used, the error message is the same)

    Any clue? I'm using Windows2000, Java 2 SDK, V1.4.0.

    Thanks a lot for the help!

    Soder
    //////////////////////////////////////////////////////

    java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory

        at net.didion.jwnl.util.MessageLog.<init>(MessageLog.java:11)

        at net.didion.jwnl.dictionary.Dictionary.<clinit>(Dictionary.java:25)

        at java.lang.Class.forName0(Native Method)

        at java.lang.Class.forName(Class.java:140)

        at net.didion.jwnl.util.factory.Element.install(Element.java:31)

        at net.didion.jwnl.JWNL.initialize(JWNL.java:157)

        at net.didion.jwnl.utilities.Examples.main(Examples.java:38)

    Exception in thread "main"

     
    • Rustam Kasad

      Rustam Kasad - 2004-07-20

      Not sure if you were able to fix your problem.  But I downloaded the org.apache.commons library from the Apache website:

      http://commons.apache.org/

      After adding it to my classpath, I was able to compile properly.

      However, I'm still not what to put in the properties file.  Also, I'm missing that utilities/Examples.java file.

       
    • Anonymous - 2004-07-22

      During the run-time , I've got the same message while initializing JWNL

       
    • Anonymous - 2004-07-22

      I use jwnl 1.3 et Wordnet 2.0

       
    • Jing

      Jing - 2005-02-04

      Hey, i got the same error. You forgot to add the commons-logging.jar into your classpath...

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks