Help about JWNL1.2

Help
Anonymous
2003-01-03
2003-05-30
  • Anonymous - 2003-01-03

    Hi, I've got JDK 1.4, WordNet 1.7, JWNL 1.2 installed, but when I tried to run Examples.java, exception about NUMBER_OF_VERB_FRAMES occurred.

    I tried to fix the bug myself by extracting property files and adding <!DOCTYPE> in xml files, but some other exceptions occurred in SAXParser.

    Can anyone tell me how to fix this problem in JWNL1.2? Thank you very much!

     
    • Anonymous - 2003-01-05

      Hello!
      I have the same problem with JWNL 1.2!
      As I understand, it occures while processing property file, not after this. And I'm also can't fix this problem...

       
    • Michele Lamarca

      Michele Lamarca - 2003-01-05

      Hello, the problem occurs when you're using a locale different from "en".

      JWNL searches for JWNLResource_YOURLOCALE.properties.

      To fix this, you can extract those files, put them in the same dir of Examples.class, and rename them according to your locale.

      Another fix is to change yout locale to english, putting the line

      java.util.Locale.setDefault(java.util.Locale.ENGLISH);

      before initializing JWNL.

       
    • Anonymous - 2003-01-06

      That really worked! Thank you very much for your help!

       
    • John Didion

      John Didion - 2003-01-07

      This was actually a bug in JWNL.initialize(). I have fixed it and re-uploaded the JWNL1.2 files. You will now be able to use JWNL without extracting the resource files or changing your default locale.

       
    • Paul Adams

      Paul Adams - 2003-05-30

      This bug still seems to be present in jwnl12_jdk14_src.zip, but not in the jar file I think.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks