JWNL Getting Started

  • Ray

    Ray - 2004-11-21

    Hi everyone, I have just dl jwnl13rc3_src.zip, however I have a problem compiling the project. I am using JBuilderX as an IDE and it seems like that there is a problem importing the org.apache.commons.logging package. Can anyone please guide me from here.

    Also do I require any additional software to be able to use JWNL? ... and do I require WordNet to be installed on my pc as well?

    Thanks for your time

    • leeo

      leeo - 2004-11-22

      yes you need wordnet

      u need the pakages in classpath you should be able to set those in Jbuilderx to save you doing it all the time.

      few other topics on forum describe the things you need to know too.

    • Ray

      Ray - 2004-11-22

      Great .. thanks a lot .. I have added the jar file and managed to get it compile and run

    • starnite

      starnite - 2004-11-30

      Hi, I am new to JWNL and I encountered the same problem of importing the org.apache.commons.logging package. I tried setting the classpath to include 3 jar files - jwnl.jar, utilities.jar and commons-logging.jar. However, I still could not compile the Example.java codes. How can I overcome this problem?

      • leeo

        leeo - 2004-12-04

        are u sure thats all of them? mind you sounds about right. i used an ide bluej to get my paths sorted makes life simple ;) i say this because the path problem is common to many programming situations ive tried doing this kind of thing manually in the classpath when i compile but with even one or 2 deps it becomes labourious.

        are you using an ide?

        if ur still stuck gimme another shout.

    • MAB_71

      MAB_71 - 2005-07-07

      Hi, when I downloaded the JWNL 1.2.1 and unzipped it I had only two .jar files, jwnl.jar and utilities.jar. Hence my java IDE program complains about not finding the followin packages:

      import net.didion.jwnl.util.logging.*;
      import net.didion.jwnl.util.logging.Level;

      ...which is understandable. however, where do I find these files? Is there something like a logging.jar??

      Any help appreciated, I need to get this tool working!!

    • MAB_71

      MAB_71 - 2005-07-08

      No worries!

      I downloaded version 1.3 of JWNL (instead of 1.2.1) and then it worked properly.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks