SourceForge has been redesigned. Learn more.
Close

Viewing "geography" data

2011-07-12
2013-06-05
  • Nobody/Anonymous

    OpenJUMP worked perfectly with "geometry" columns.
    However when I tried to visualize data from a table with a "geography" column I got the following error:
    org.postgresql.util.PSQLException: ERROR: function extent(geography) does not exist   Hint: No function matches the given name and argument types. You might need to add explicit type casts.   Where: PL/pgSQL function "find_extent" line 8 at FOR over EXECUTE statement (Runtime Exception)
    Where should I add the type cast?

    Thank you all.

    Michael

     
  • michael michaud

    michael michaud - 2011-07-15

    Hi,

    Right, OpenJUMP is not ready for Geography data type reading. I'll add on the roadmap : check if PostGIS "Geography" data type can easily be detected and converted into Geometry to be loaded into OpenJUMP.
    Did you try to convert geography to geometry in a ad hoc sql query (SELECT geog_column::geometry from table…) ?

    Michaël (mmichaud)

     
  • Nobody/Anonymous

    Hi,
    I have the exact same problem with PostGIS2, Postgres9, OJ 1.4.2, except I'm querying a "geometry" column. Do you have any idea why ?

    Mathieu Petit

     

Log in to post a comment.