error parsing

  • stols

    stols - 2009-09-18


    I am using Java Treeview to analyse some microarray, and first and foremost, thank you for your work on this program.
    However I seem to have a problem that I can't solve.
    When loading my coordinates file, the parsing invariably fails (error message is: loading C:\Program Files\TreeView-1.1.1-win\coordinates\4x44k.pcl …
    Finding Cdt Dimensions
    error parsing File: LoadException 1: Error Parsing CDT: java.lang.NullPointerException
    parse cannot succeed. please fix.)

    The full stacktrace seems to be this:
    I : while parsing cdt got error null
        at edu.stanford.genetics.
    treeview.model.TVModelLoader2.findCdtDimensions(Unknown Source)
        at edu.stanford.genetics.treeview.model.TVModelLoader2.parseCDT(Unknown Source)
        at Source)
        at edu.stanford.genetics.treeview.model.TVModelLoader2$1.construct(Unknown Source)
        at edu.stanford.genetics.treeview.SwingWorker$ Source)

    The strange thing is that it fails on windows and Linux, but works on MacOsX.
    Sadly, I can't use it on MacOS it anymore :/

    I thought at first that I have a version problem (the mac version is 1.1.1) and I used 1.4r3 on Windows, but I tried again with 1.1.1 on Windows and it doesn't work either?

    Could you please help me understand what is going wrong?


  • Alok Saldanha

    Alok Saldanha - 2009-09-18

    it's tough to diagnose without being able to see the file… if you make an extract of your coordinates file (say the first 100 lines) does parsing still fail in the same way? maybe you could post that or email it to me (you can use


Log in to post a comment.