net/sourceforge/jtds/jdbc/Driver : Unsupported major.minor version 51.0

  • deflepfollower

    deflepfollower - 2014-02-25


    i'm trying to configure jTDS Microsoft SQL into Squirrel SQL , under

    Change Driver: jTDS Microsoft SQL > Extra Class Path

    After i add the jar file from my local machine path : C:\sQuiRReL_SQL\squirrel-sql.jar

    there's an error pop up: ":net/sourceforge/jtds/jdbc/Driver : Unsupported major.minor version 51.0"

    and the error message at the bottom reads:

    Could not find class net.sourceforge.jtds.jdbc.Driver in neither the Java class path nor the Extra class path of the jTDS

    Microsoft SQL driver definition:
    java.lang.ClassNotFoundException: net.sourceforge.jtds.jdbc.Driver

    Any advise appreciated. Thanks.

  • momo

    momo - 2014-02-25

    too lazy to do a simple google search?

    Sorry, but this sometimes gets really annoying. Never mind, you are using a JDK/JRE below version 1.7. You could switch to jTDS 1.2.x that only requires Java 1.3.

    Last edit: momo 2014-02-25

Log in to post a comment.