HELP -- Jar hell!

Help
2010-01-21
2013-01-10
  • James Edwards

    James Edwards - 2010-01-21

    I'm trying to use JSI in an eclipse project.  I added jsi-1.0b2p1.jar, trove-0.18.jar, and sil-0.43b-am1.jar to the build path, and eclipse doesn't report any errors, but whenever I run a program that instantiates an RTree, the classloader fails to load gnu.trove.TIntProcedure.  And yet if I instantiate a TIntProcedure in the line before I instantiate the RTree, there are no problems. 

    It doesn't make any sense.  I have tried everything.  Including jsi as separate eclipse project didn't work.  I even created a special version of jsi-1.0b2p1.jar that contains all the class files from trove-0.18.jar and sil-0.43b-am1.jar, but the error still occurs when I use that class.  Any help would be much appreciated!

     
  • Aled Morris

    Aled Morris - 2010-05-30

    This sounds strange - if you can zip up your project and put it somewhere I can download it, I'll take a look.

    Aled.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks