JSch escape character problem

  • ismet zeytinci

    ismet zeytinci - 2010-06-01


    I have an interesting problem about JSch (Actually, I am not sure that the problem is caused by either SSH2 or JSch; but I think the root of the problem is JSch, since I don't have a problem while using SSH Client). Let me brief explain about the problem:

    There is a negative (-) sign in my command using for updating a Unix user's profile via EtaUtil tool. However, JSch interprets this sign as an operator and it gives me an error . Despite of using double quotation ", single quotation ', back slash, tilde ~ (default escape character value of SSH2) … vs. it always gives me the same error and it goes on interprets as an operator.

    My command is below:

    etautil -d OPCEADMIN1 -u XXX -p XXXX UPDATE 'eTETCAccountContainerName=Accounts,eTETCDirectoryName=XXXX,eTNamespaceName=UNIX - etc' eTETCAccount eTETCAccountName=XXXX to eTSuspended=0

    And the error :
    'eTETCAccount' is not a valid operator for keyword 'etc'

    How can I fix that problem, could someone help me? Thanks.

  • ismet zeytinci

    ismet zeytinci - 2010-06-07

    Hello again,

    I have figured out this problem and want to share my solution in order to help someone struggling with this kind of problem.

    I have decided to run command as a script on remote machine; since I don't have a problem while using SSH Client. So, the problem is solved.


Log in to post a comment.