More compat issues with Non-Java version

Help
ericjln
2009-06-10
2012-09-17
  • ericjln

    ericjln - 2009-06-10

    I am using the Windows Password Safe version 3.17 (2628), and I am trying to migrate to jpwsafe on linux 0.8-beta1.107.

    jpwsafe can open a new password db from Password Safe (pwsafe-test.psafe3), but jpwsafe can't open my existing Password Safe. It just throws up an "incorrect password" error.

    I have tried to use pwsafe-3.17 to merge my existing pw DB into the new DB, but after doing so, jpwsafe-0.8-beta1 can no longer open the pw db.

     
    • David

      David - 2009-06-22

      Hi Ericjln,

      as you might have seen (latest lpwsafe news item), there is a bug in Beta1 regarding non-trivial passphrases.

      Apart from this there is probably a problem with the latest Passwordsafe Version, as a new field was introduced with it (This is a bug, see https://sourceforge.net/tracker/?func=detail&aid=2462736&group_id=243370&atid=1122415).

      Both issues will be solved before beta2. If you like you can be a pre beta2 tester to insure your problems are solved ;-)

      Cheers,
      Roxon

       
    • ericjln

      ericjln - 2009-06-10

      Second experiment:

      using pwsafe-3.17, I created a newDB.psafe3. I create 1 entry in newDB.psafe3, save, and quit pwsafe-3.17

      I then open newDB.psafe3 with jpwsafe-0.80beta1, add a second entry, save, and quit.

      Finally, I try again to open newDB.psaf3 with pwsafe-3.17. It gives error about bad password or corrupted database. I quit and try to open with jpwsafe-0.8beta1, and it gives the "incorrect password" error.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks