SourceForge has been redesigned. Learn more.
Close

Problem getting JPasswords running

Help
2007-10-08
2013-05-13
  • Nobody/Anonymous

    Hallo,

    I just made a complete new Debian Etch installation on one of my computers.
    I did install the new Sun Java runtime Environment (jre1.6.0_03 ) and got the new JPasswords Java archive ( jpws-0-5-0.jar ).
    Then I tried to run JPasswords:
    Run command:
       java -jar /usr/local/JPasswords 
    where java is the link: java -> /usr/local/jrel.6.0_03/bin/java
    and I got the following result:

    wer@rrwork:/usr$ java -jar /usr/local/JPasswords
    Exception in thread "main" java.lang.NoClassDefFoundError: org.jpws.pwslib.persi               st.AbstractFTPAdapter
       at java.lang.Class.initializeClass(libgcj.so.70)
       at java.lang.Class.initializeClass(libgcj.so.70)
       at org.jpws.front.Global.<clinit>(Unknown Source)
       at java.lang.Class.initializeClass(libgcj.so.70)
       at org.jpws.front.PwsafeJ.main(Unknown Source)
    Caused by: java.lang.ClassNotFoundException: sun.net.TelnetInputStream not found                in gnu.gcj.runtime.SystemClassLoader{urls=[file:/usr/local/JPasswords], parent=               gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
       at java.net.URLClassLoader.findClass(libgcj.so.70)
       at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.70)
       at java.lang.ClassLoader.loadClass(libgcj.so.70)
       at java.lang.ClassLoader.loadClass(libgcj.so.70)
       at java.lang.Class.initializeClass(libgcj.so.70)
       ...4 more
    wer@rrwork:/usr$ pwd
    /usr
    ------------------------------

    Since I don't know Java I cannot figure out what went wrong.
    Somhow it appears to me that something like a language definition is lacking.

    Coukld anyone give me some help how to fix it?

    Thanks in advance

       W. Ritter

     
    • Nobody/Anonymous

      Problem 'solved'
      After I changed the /usr/bin/java link from GNU Java to the SUN Java JPasswords is starting up.
      I hope everything else running with Java is still working. Well I will see.

        W. Ritter

       
    • Wolfgang Keller

      Wolfgang Keller - 2007-10-10

      Hello

      There are some SUN-specific class references in JPasswords to implement FTP functionality.

      You could start JPWS using a direct reference to the SUN JRE, thus avoiding redefinition of the global JAVA link. I'm not sure how this runs in Linux but it should look like this:

      <sun-jre-directory>/bin/java -jar <jpws-directory>/jpws-0-5-0.jar [jpws-options]

      Regards
      - Wolfgang

       

Anonymous
Anonymous

Cancel  Add attachments