Jboss 3.2.5 Deployment Error

  • err108

    err108 - 2004-09-27

    I'm trying to deploy the jpivot.war (v1.2.1) under Jboss 3.2.5/Tomcat5.0 and I get the following error during deployment. 

    com.tonbeller.wcf.utils.SoftException: java.lang.ClassNotFoundException: No ClassLoaders found for: com.tonbeller.wcf.format.BooleanHandler

    I saw a post similar to this from about a year ago, but no solution.  Has anyone come across this error before and knows how to solve it?


    • Sherman Wood

      Sherman Wood - 2004-09-27
    • Ati Rosselet

      Ati Rosselet - 2004-09-27

      havent tried 3.2.5 yet.. we are currently using 3.2.3 and all is fine.. but I'll take a look this week.  Also..  it mght be worthwhile going straight to Jboss 4.0...  (also planning to test that this week, or early next - need to do upgrades and testing anyways)

    • err108

      err108 - 2004-09-28

      Thank you both for your replies.  I installed a fresh copy of 3.2.5, and was able to deploy successfully.  In my previous install I had updated my jboss-services.xml file and set the UseJBossWebLoader attribute to false.  I have serveral different war files installed that cannot share classes due to version conflicts.  Setting it to true allows the JPivot.war to work, but now my other apps won't.  I'll continue to look into deploying it under it's own classloader.

      Ps.   I did try Jboss 4.0 and had the same issue. 

      Thanks Again.

    • Ati Rosselet

      Ati Rosselet - 2004-09-30

      lucky you... still cant get things up on 3.2.5.. or rather 3.2.6 now..
      and jboss 4.0 does some weird things to us .. *sigh*.. back to read jboss docs... :)


Log in to post a comment.