Josso 2: can't create activation link

  • Vsevolod

    Vsevolod - 2014-06-25


    I've created IdP, SAML2 local service provider and Tomcat 6 execution environment using Atricore console. Also I've linked IdP with SP. See screenshot for details:

    But when I try to create Activation link between service provider and Tomcat environment the link simply doesn't appear without any errors or warnings.

    Could you help?

    • Sebastian Gonzalez Oyuela

      JOSSO 2.4 introduces changes to the modeling notation that specifically modify the way Local SAML2 Service Providers and the applications are represented. In JOSSO 2.3 all the information about the actual application (i.e. application base location, type, etc.) was stored as part of the activation connection between the SP and the execution environment (i.e. Tomcat, IIS, etc).

      In the new JOSSO 2.4 a new element was created to make the application a first class modeling component providing a better view of the entire deployment. You don't have to drill down into each activation to verify the type of application, etc.

      The new element is named Resource and there is a specific drawer that contains all resource types. The most common use-case is to represent an application that will be SSO enabled by installing a JOSSO agent. (i.e. a custom web application deployed on Tomcat, IIS, JBoss, etc). To model this scenario a JOSSO 1 resource is used. JOSSO 1 resources are web applications that will be connected to JOSSO using a JOSSO 1 agent. (Since JOSSO agents work with both JOSSO 1 and 2, but are provided by JOSSO 1 the name was JOSSO 1 resource was selected).

      I hope this helps.

      Last edit: Sebastian Gonzalez Oyuela 2014-08-21
  • Daniel O'Leary

    Daniel O'Leary - 2014-07-03

    I have the exact same issue. What gives? I even followed the JOSSO2 Quick Start, and a plain Service Provider does not exist in the Providers drawer. So I use SAML2 Local, and it will not let me connect to the Tomcat execution environment.

  • Edésio Gobetti Schemes Junior

    I have the same situation. I didn't find another service provider, then I used the SAML2 Local. But I can't connect my SP to the Tomcat.

  • androider

    androider - 2014-07-16

    I think in Josso 2.4 you need to connect the SP with a resource for example (Alfresco) using a service connection, then you can connect the resource to an execution environment (Tomcat) using the activation connection

  • Edésio Gobetti Schemes Junior

    Sorry, I already used a resource. In my case, I used the Self Service Resource, but this kind of resource does not permit the relationship with tomcat. Do I need to use another option of resource ?

  • Yang Huajie

    Yang Huajie - 2014-08-17

    I have the exact same issue. Is it a bug in latest version?

  • Jayesh

    Jayesh - 2014-10-10

    I have used JOSSO1 as resource and it is allowing me to complete the appliance setup and I can save it as well. I am also able to reactivate it, but for some reason it is unable to build the bundle or export the appliance configuration.

    Last edit: Jayesh 2014-10-10
  • Jayesh

    Jayesh - 2014-10-10

    See attached screenshot for setup I have done

    Last edit: Jayesh 2014-10-10
  • Abhinav Maheshwari

    I have also done everything as mentioned in Getting Started but the activation link is not made. Can you please update the Getting Started guide ? I think many of us would be happy to contribute, but the documentation of JOSSO2 is very minimal - for example - how can I add custom written Identity Provider / Service Provider / Stores etc. ?

    After incorporating your suggestion of JOSSO1 app as resource, and Reactivation, Tomcat stops running at all with a NullPointerException during parsing of josso-agent-config.xml. I am really surprised at what used to be a great open source. Is JOSSO2 community edition completely unsupported and we should go back to JOSSO 1 ?

    Last edit: Abhinav Maheshwari 2015-02-25

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks