Feedback on existing Remote Applications

2010-06-11
2013-05-28
1 2 > >> (Page 1 of 2)
  • Jean-Marc Harvengt

    Use this forum to give feeback on existing remote applications

     
  • Markus Becker

    Markus Becker - 2010-06-23

    Hi.

    Its possible to the increase the framerate here? Would be really usefull to use it as remote movie player..

    Regards.

     
  • Markus Becker

    Markus Becker - 2010-06-23

    PluggIt … i mean.

     
  • Jean-Marc Harvengt

    Hi,

    It is true that the frame rate is really limitting.
    Wired is better than wireless.
    If you lower the resolution in the batch file, you can improve it.
    But from the moment you will stream video, the compression will become uneficient.

    Also you will miss sound!.

    J-M

     
  • Markus Becker

    Markus Becker - 2010-06-24

    Well, PlugIt it already very usefull to show pictures or use it as browser.  But is it technical possible over the libApi to build a remote app for video/audio wireless transfer with HD quality to the tv?

    best regards

     
  • Anonymous - 2010-06-24

    I was going to test Plugit , but it's not working on Windows 7 :
    do we know why or what is needed to make it work?
    tx

     
  • Anonymous - 2010-07-16

    Any idea when Pluggit is compatible with win7. Is it because of mirror driver or something else?

     
  • PinkyPanther007

    PinkyPanther007 - 2010-07-25

    Hi,

    is it possible to use pluggit under Linux? While the sample and hello world application work, all I get when trying to compile pluggit the same way is:

    hm@hm-ubuntu:~/develop/jointspace/PluggIt$ DIRECTFB_VOODOO=../DirectFB_Voodoo make
    make: Entering directory `/home/hm/develop/jointspace/PluggIt'
    cd src && ./gen_classes.sh Exception.cxx OutOfMemoryException.cxx Clock.cxx FPS.cxx Options.cxx Random.cxx Updates.cxx Runnable.cxx Thread.cxx Scaler.cxx View.cxx Source.cxx SourceX11.cxx Main.cxx > classes.cpp
    /bin/sh: ./gen_classes.sh: Permission denied
    make: ***  Error 126
    make: Leaving directory `/home/hm/develop/jointspace/PluggIt'
    make: ***  Error 2

    Is there any way to use the cygwin package of any application or provide the source for the apps?

    Best Regards

     
  • Jean-Marc Harvengt

    Hi,

    Pluggit was originally developed for Linux.
    You can delete classes.cpp and the makefile should regenerate it for Linux.

    Regards,

    J-M

     
  • Anonymous - 2010-08-30

    Hi,

    Today was my first test, and I'm rather happy with Jointspace on my 9704 tv set.

    Here are my feedback :

    - pluggit :
       -> it works if the driver is NOT installed silently
       -> but where is the mouse cursor on screen ?
    - photoviewer :
      -> for an unknown reason, I can't see any picture, only white box flying on the screen…
      -> so laggy… is there any way to get a smooth animation when white squares are morphing/moving ?

    Some information now about my installation :
    - TV set : 40PFL9704
    - PC : Windows XP 32 bits, running on a Smasung NC10
    - connection between tv and PC : wifi

    David

     
  • Samtra

    Samtra - 2010-09-05

    Dear David, Good luck that you too managed to get it running.
    The input lag is several seconds. Very bad indeed. :-(
    My 9704 is connected with WLAN (G) too.
    The cursor is gone maybe because the PNM is ON?

    Opening HOME screen does nothing to pluggit, but opening setting screen kills the process.. hmm strange.

    This works for my Windows 7 32bit:

    First I tried running bat files normally with no luck.
    Then I decided to use the windows support modes.

    Use Windows Vista compatibility for two exe files:
    pluggit\pluggit.exe
    pluggit\driver\vista\setupdrv.exe

    run pluggit\driver\vista\install.bat

    run pluggit\1280x720xRGB16_brg_auto.bat
    Close the CMD box to kill the process (to exit).

     
  • Michael Thoen

    Michael Thoen - 2010-10-04

    I tried the samples for android (didn't compile myself but took the apk's from the bin directories of the samples) and the remote app and the androidbeam both worked. I'm using a HTC Magic with CyanogenMod 6 on it (Android 2.2).

    I would love Philips to implement something like xbmc's webserver http api (http://wiki.xbmc.org/index.php?title=WebServerHTTP-API) which makes it very easy to send commands over wifi/network to the television and would also allow you to communicate current status/settings back over the network. The JointSpace solution is at least something but a webserver would mean that every device could access the television in the same way and not a lot of programming knowledge is needed. A webserver can be very lightweight so should be able to run on the television. This would also allow you to do cool things like start xbmc, which would then run a script to execute a script which would send commands to the http-api on the television to set it to the correct hdmi input and setting the enhancers to specific settings. This could also allow two way communication between devices since messages could be sent in both direction (or status messages), sort of a handshaking… Keep on dreaming I guess…

    But at least let me thank you for porting the remote to the Android SDK.

     
  • H van Gent

    H van Gent - 2010-10-07

    Installed Pluggit in W7-32 and cannot get sound to work. Is this right or am i doing something wrong.
    Pluggit display interface is working very well on a Wifi N-network, only films are a bit sluggish.
    Here's the log, where i find protocols (SNDxxxx = sound??) are not found. Is there a way to correct it?

    Thanks in advance.

    D:\pluggit>pluggit.exe -r 1280x720 -f RGB16

       ~~~~~~~~~~~~~~~~~~~~~~~~~~| DirectFB 1.4.0 |~~~~~~~~~~~~~~~~~~~~~~~~~~
            (C) 2001-2009  The world wide DirectFB Open Source Community
            (C) 2000-2004  Convergence (integrated media) GmbH
          -------------------------------------------

    (*) Direct/Interface: Using 'Requestor' implementation of 'IDirectFB'.
    (!) Direct/Thread: Could not set scheduling policy to OTHER!
        -> No such file or directory
    (*) Direct/Thread: Started 'Voodoo/Player' (-1)  <0>..
    .
    (*) Voodoo/Player: Detected 3 interfaces
    (*) Voodoo/Player:   {AA100A10-00F2-45D0-9B77-2C031DDD4B82} (192.168.0.255)
    (*) Voodoo/Player: Received message from ourself (192.168.0.112)
    (*) Voodoo/Player: Received SENDINFO from 'PhilipsTV' (192.168.0.115)
    (*) Voodoo/Player:   {4EDCF910-A4FC-4448-A44E-6778AE3DFF07} (192.168.1.255)
    (*) Voodoo/Player:   {81E0A436-F0A3-11DE-9C91-806E6F6E6963} (127.255.255.255)
    (*) Voodoo/Player: Received message from ourself (127.0.0.1)
    (*) Voodoo/Client: Looking up host '192.168.0.115'…
    (*) Voodoo/Client: Connecting to '192.168.0.115:2323:2323'…
    (!) Voodoo/Manager: getsockopt() for SO_SNDLOWAT failed!
        -> Protocol not available
    (!) Voodoo/Manager: getsockopt() for SO_RCVLOWAT failed!
        -> Protocol not available
    (!) Direct/Thread: Could not set scheduling policy to OTHER!
        -> Protocol not available
    (*) Direct/Thread: Started 'Voodoo Dispatch' (-1)  <
    0>…
    (!) Direct/Thread: Could not set scheduling policy to OTHER!
        -> Protocol not available
    (*) Direct/Thread: Started 'Voodoo Socket' (-1)  <0>…

    (*) Voodoo/Manager: Created remote super interface 'IDirectFB'.
    (*) Direct/Interface: Using 'Requestor' implementation of 'IDirectFBDisplayLayer
    '.
    (*) Direct/Interface: Using 'Dispatcher' implementation of 'IDirectFBEventBuffer
    '.
    (*) Source/Win32: Window 0,0-1280x800, name ''
    (*) Direct/Interface: Using 'Requestor' implementation of 'IDirectFBWindow'.
    (*) ret 0
    (*) Direct/Interface: Using 'Requestor' implementation of 'IDirectFBSurface'.
    (!) Direct/Thread: Could not set scheduling policy to OTHER!
        -> Protocol not available
    (*) Direct/Thread: Started 'SourceWin32' (-1)  <0>…

     
  • Jean-Marc Harvengt

    Hi,

    Sound is not implemented yet.
    Don't expect very high frame rate by the way.
    DirectFB over Voodoo is only compressing GFX using RLE.
    This form of compression is not suitable for video data.
    We unfortunately don't have a HW video encoder on board yet!

    J-M

     
  • Jean-Marc Harvengt

    Hi,

    I have used XBMC on my XBOX in the past to watch my video collection on my TV!
    I was not aware that there was a way to control playback via HTTP API.

    Our 2k10 sets supports DLNA push  and playback control over UPNP.
    In future we will expose a jointSPACE API to play any type of content.
    I know jointSPACE  is a bit proprietary API but we currently don't have a HTTP server running in the TV.

    Thanks for the info. It is good to share ideas sometimes!
    Any plan on Android. I am looking for somebody to create a nice Remote Control application!

    J-M

     
  • Eric

    Eric - 2010-10-24

    Hi there,

    Just a feedback from the iphone Remote Philips TV app from Tim Vandecasteele.
    I've been waiting for such an app for months now (there's been TV apps for Samsung etc…but Philips was so missing).!!!!
    It's working like a charm. I haven't tested all the functionalities yet but basic operations work just fine (+ display of the pictures stored on the iphone is a great nice to have).
    Well Tim I couldn't see your email address or website but thank you so much about this app and keep up with the great work on it!
    I'll put a comment on the appstore as soon as I have tested all functionalities (this will of course be a positive review but just want to see if there's room for improvement).
    And the app is free!!!! so jump on it!!!

     
  • kl156

    kl156 - 2010-12-06

    Hi,

    great iPhone App, and nice because you dont have to change to TV Remote to switch programs ;-)

    The Keyboard is very helpful for NetTV, but as already written in the iTunes comments, it has some problems especially with german language setting in the TV. The Order on Philips TV (with a IR remote) is for example "aäbc…" which gives an "ä" instead of a "b". So one solution could be to change to english on the TV or (better) to add language support to the App. Or to change the Philips TV setting.

    My Wishlist for the app is a Page with shortcuts to the different HDMI/EXT Ports to switch between Inputs and not to go through the Home Screen. (and aiPad Version of course)
    BTW: ist it possible for the SAT Models to directly switch to SAT? Is there a IR-Remote Code assigned for that?
    The TV defaults to DVB-T and unfortunately it does not receive a program if a ASTRA HD+ Card is inserted…
    My TV is a 46PFL7655K/02 with DVB-S2 Tuner

    Thanks for Jointspace SW and the iPhone App.
    Klaus

     
  • Sander

    Sander - 2010-12-16

    The iPhone application does not work for me because my wifi network is not bridged with the wired section including tv. The broadcast packet from the iPhone does not reach the tv. I would like an option to statically configure the ip address of the tv, like some of the example code.

     
  • nomad

    nomad - 2010-12-21

    TV remote application for PC does not work. Black window with TV's IP at the top and 5 white dots at the bottom.

     
  • Jean-Marc Harvengt

    Did you try to swipe the black panel with the mouse?
    It should act as the Android version.

    J-M

     
  • Anonymous - 2011-01-24

    Android example works, but does not contain the full code. It is not possible to start Android development without JOINTSPACE java adapter i.e.  jar file
    There is a SVN repository, but why it is empty?

     
  • rvdk

    rvdk - 2011-02-16

    Hi,

    I'm trying to build PluggIt on the PC (using Cygwin) but I get an error building it:

    $ DIRECTFB_VOODOO=../DirectFB_Voodoo make
    make[1]: Entering directory `/js/PluggIt'
    g++ src/classes.o src/videodriver.o src/videodrivercheck.o src/KeySend.o ../DirectFB_Voodoo/lib/libdirectfb.o -lpthread -lgdi32 -luser32 -lversion libscreenhooks.a -o pluggit
    g++: libscreenhooks.a: No such file or directory
    make[1]: *** [pluggit] Error 1
    make[1]: Leaving directory `/js/PluggIt'
    make: *** [all] Error 2
    
     
  • Jean-Marc Harvengt

    Just remove libscreenhooks.a from the makefile.
    It is not used anymore.
    The makefile was not up to date. I havve re-uploaded the archive.

    Thanks,

    J-M

     
  • Jean-Marc Harvengt

    The Android samples should be ok.
    The Android discovery JNI class was updated to pass more parameters in the function.
    That might be the issue.

    Is it ok now?

    J-M

     
  • Mike Shock

    Mike Shock - 2011-03-02

    I'm trying to compile Pluggit under Linux (openSUSE 11.3)

    harvengj
    Pluggit was originally developed for Linux. You can delete classes.cpp and the makefile should regenerate it for Linux.

    pinkypanther007
    /bin/sh: ./gen_classes.sh: Permission denied

    I fixed this error by making the *.sh files executable:
    chmod a+x src/gen_classes.sh

    But then I get another error:

    make[1]: Entering directory `/opt/jointSPACE/PluggIt'
    g++ src/classes.o /opt/jointSPACE/DirectFB_Voodoo/lib/libdirectfb.o -lpthread -lX11 -lXext -lXdamage -lXfixes -o pluggit
    /usr/lib/gcc/i586-suse-linux/4.5/../../../crt1.o: In function `_start':
    /usr/src/packages/BUILD/glibc-2.11.2/csu/../sysdeps/i386/elf/start.S:115: undefined reference to `main'
    collect2: ld returned 1 exit status
    make[1]: *** [pluggit] Error 1
    make[1]: Leaving directory `/opt/jointSPACE/PluggIt'
    make: *** [all] Error 2
    

    Unfortunately I can't fix it so far… :-(

     
1 2 > >> (Page 1 of 2)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks