#390 memory problems

closed-fixed
nobody
5
2007-06-03
2007-03-26
No

Hi,

I submitted this to the developers list, but realized that it should have been submitted to the bug tracker. Sorry.

I was wondering whether the following should indeed happen, proposing that it really shouldn't :-)

I start jmol (latest from SVN:11.1.27) inside the cube directory of the jmol-datafiles, so I can load the 2px.cub.gz file several times. Initially the memory use is 13 6 64 (MB total free max, respectively, from the popup)

Next I do the following load and see what the popup tells me about the memory usage:

$ isosurface pos 0.032 "2px.cub.gz"
memory use is : 27 12 64

$ isosurface pos 0.032 "2px.cub.gz"
memory use is : 40 19 64

$ isosurface pos 0.032 "2px.cub.gz"
memory use is: 48 21 64

$ isosurface pos 0.032 "2px.cub.gz"
memory use is : 61 27 64

$ isosurface pos 0.032 "2px.cub.gz"
memory use is : 64 25 64

$ isosurface pos 0.032 "2px.cub.gz"
memory use is : 64 20 64

$ isosurface pos 0.032 "2px.cub.gz"
and Jmol crashes.

I initially encountered the problem with a huge cube file (about 50MB big) and noticed that when I had the first surface drawn and written the isosurface JVXL file. I could zap the model but the memory was not released. I also noticed that as I waited the amount of free memory kept diminishing until Jmol crashed. I decided to try to reproduce a similar problem with a cube file that is already available in the datafiles. Turns out that I didn't even have to write a JVXL file to start making this happen.

Thanks,
René

Discussion

  • Bob Hanson

    Bob Hanson - 2007-06-03

    Logged In: YES
    user_id=1082841
    Originator: NO

    this was fixed in one of the updates. Currently that same sequence never goes over 23/25Mb on my machine, and then it drops back to 15/25Mb as garbage is collected automatically by Java.

     
  • Bob Hanson

    Bob Hanson - 2007-06-03
    • status: open --> closed-fixed
     
  • Seboschwieg

    Seboschwieg - 2007-06-04

    Logged In: YES
    user_id=1688349
    Originator: NO

    Verified Fixed. Thanks for fixing this! I just started to implement MO-surfaces on my wiki and this kept me from advertizing them.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks