Hi ,

I went through your blog , it was really helpful .. but still I didnt get some inform on the subtypes..

I have registered my service with subtype using mdnsreponder(applebonjour) on my linux pc
. And I am trying to browse the service using jmdns (here I have jmdns.jar file) on my Galaxy phone .

I registered the service using the below command

$dns-sd -R SMARTCAM _smartplace._tcp.,_wcam local 80  "u=test" 

When I browse with out subtype in the service type list of jmdns I get the proper response . i.e

ServiceInfo[] https = jmdns.list("_smartplace._tcp.local.");

but If I try with the below options , It could not list anything -> response was null

Map<String, ServiceInfo[]> ressub = jmdns.listBySubtype("_wcam._sub._smartplace._tcp.local.");

It worked for the avahi

$avahi-browse   _wcam._sub._smartplace._tcp.

It worked with the avahi browse ..

Now I want confirm that am I doing the sub type search properly  in jmdns  .? I serached for some document but could not get the some info which can help  ..