javax.bluetooth.BluetoothStateException: Busy

  • joint_striker

    joint_striker - 2011-07-10

    When trying to connect to the server over Bluetooth I get this error: javax.bluetooth.BluetoothStateException: Busy
    At some point when the client inquiries for devices I can see the PC bluetooth name being found but then that error pops-up. I've tried different setups but to no avail, odd because I recall successfully using this tool 2 or 3 years ago, although I don't remember which version I used back then. The phone I'm using is a Nokia 6680 (S60 v2). Does someone have a clue on what the problem may be? Thanks

  • joint_striker

    joint_striker - 2011-07-10

    I've had a breakthrough with JM2PC since my last post.

    Turns out that errors either:
    - Manual server connection: SymbianOS error = -34: General:System error
    - Automatic server connection: javax.bluetooth.BluetoothStateException: Busy
    Are not the a JM2PC client or server problem, instead it's the PC Bluetooth configuration that jeopardizes the connection.
    I'm not about to explain in full detail how I solved it, but if someone needs more help just ask..

    I have a Conceptronics CBTU2 bluetooth dongle, but I don't like the BlueSoleil software so in my case I was using the native Windows Bluetooth Support Service and I always had the above errors with JM2PC. When I decided to install and try the BlueSoleil software (and drivers) it started working. At this point I only managed to establish a connection by manually setting the server address in JM2PC BT client, but anyway it worked.

    Now the problem is that straightforward applications like SmartCam ( stopped working with Bluetooth returning a connection error. I might get it to work with BlueSoleil but hadn't the time yet. What I did is I uninstalled BlueSoleil and SmartCam worked again, so at this point I have to alternate between native Windows Bluetooth Support Service and BlueSoleil.

    I hope this helps.

  • kyle

    kyle - 2011-09-17

    good day ner0phyte can you help a little bit I got the same exact error  when i use the software can you help me pls thanks

  • joint_striker

    joint_striker - 2011-09-17

    Hi, kylemarc0.

    Well, I can't help further than my previous post. I'll have to repeat myself a bitI… for me it ultimately it was a PC problem. By that I mean that the app I was trying to connect form the PC to the phone was only compatible with Windows Bluetooth Support Service and not a third party software. It's like for Wi-Fi, you have some Wi-Fi drivers which come with a brand made app for connecting to networks and monitoring your card and nearby networks, you either use the brand app to connect to networks or you use Windows own Wireless Zero-Configuration service (WZC), from your taskbar tray re. For Bluetooth it is the same, you can install the Bluetooth drivers and the brand app (in my case was the generic BlueSoleil app)  or you can just install the drivers and use Windows integrated Bluetooth manager service. Make sure you create a system restore point before you add or remove any software, it may eventually spare you some headaches. If this doesn't work for you I don't know how you can solve you problem.

  • kyle

    kyle - 2011-09-18

    thanks i'll try your advice I'll update you regarding this thing thanks again

  • joint_striker

    joint_striker - 2011-09-18

    Another thing kylemarc0, if you read my two previous posts you'll understand that I contradicted myself.
    I forgot how it was solved but the first of my two previous posts was correct.
    My mistake was in saying in the last post that it worked using  Windows Bluetooth Support Service, in fact it was the other way around, it didn't work using Windows Bluetooth Support Service but worked using BlueSoleil Bluetooth software.
    The problem for me was that it made JM2PC work but turned incompatible other Bluetooth apps, so I had to install BlueSoleil exclusively for JM2PC. As for other dongles I don't know which software they're packed with, but I'm pretty sure that in my case JM2PC failed to work because of  some Windows Bluetooth Support Service incompatibility. I'm not sure where I got that idea, I think it was browsing some development forums at Nokia where someone talked about Bluetooth problems with Windows Bluetooth Support Service. So I'm sorry for the mistake.

  • kyle

    kyle - 2011-09-19

    i followed your first instruction it was solved but then another problem came out it says can't make connection null, anyway thanks for the help


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks