Ubuntu Karmic (9.10) startup error

Help
Anonymous
2009-11-03
2013-04-30
  • Anonymous - 2009-11-03

    Hi,

    Jin is throwing an exception when I attempt to start it, after upgrade to
    9.10 (worked great before the upgrade).

    Full traceback:

        Exception in thread "main" java.lang.ExceptionInInitializerError
           at java.lang.Class.initializeClass(libgcj.so.10)
           at java.lang.Class.forName(libgcj.so.10)
           at java.lang.Class.forName(libgcj.so.10)
           at free.jin.JinMain.<clinit>(JinMain.java:72)
           at java.lang.Class.initializeClass(libgcj.so.10)
        Caused by: java.lang.NullPointerException
           at javax.swing.text.JTextComponent.loadKeymap(libgcj.so.10)
           at free.workarounds.SwingFix.<clinit>(SwingFix.java:73)
           at java.lang.Class.initializeClass(libgcj.so.10)
           …4 more

    Any ideas? Thanks!

    -AJ

     
  • Anonymous - 2009-11-03

    Self-reply, maybe it will help someone:

    After the upgrade, Ubuntu changed the /usr/bin/java symlink to point to the gij java binary (the GNU libgcj implementation). Switching it back to the Sun java version (/usr/lib/jvm/java-6-sun-1.6.0.16/bin/java or similar) should fix the problem.

     
  • Anonymous - 2010-02-12

    How exactly does one change it back? I checked in the system->Preferences->Java Control panel thing and it is still /usr/lib/jvm/java-6-sun-1.6.0.16/bin/java, but I still get a start up error.

    I get an error java.io.EOFexception…

    Please help

     
  • Anonymous - 2010-02-12

    Seems, like a Sourceforge bug, hehe, but actually, I posted the above post, not AJ.. strange.

     
  • Bob

    Bob - 2010-04-23

    Change the symlink in /usr/bin to point to the right place (and not to /etc/alternatives or some such).

    This solves all sorts of problems in all sorts of apps.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks