Linux audio problems

2005-09-11
2013-04-30
  • Jim Showalter

    Jim Showalter - 2005-09-11

    Alex, your suggestion of adding the line:
    "export JAVA_OPTS='-Dfree.util.audio.player=free.util.audio.ExternalAppAudioPlayer'"

    to the 'jin' script and copying the files 'play' and 'sox' from Jin 2.12.1 to the Jin 2.13.1 directory, fixed the audio problems that were bugging me in Jin 2.13 and 2.13.1.

    Thank you - the new Jin is great!

    edroid

     
    • Jim Showalter

      Jim Showalter - 2005-09-14

      I should have chosen "Linux audio problems - solved".

      Sorry about that.

       
    • Bob

      Bob - 2005-10-08

      I tried this workaround on my Ubuntu Linux 5.0.4 system and get this:

      free.util.audio.ExternalAppAudioPlayer is not supported on your system - audio disabled.

      Puzzling, as the 'util.jar' clearly contains this method.... can anyone enlighten?  Thanks.

       
      • Alexander Maryanovsky

        As implied by its name, the method required an external app to work. Namely, an executable named "play" in Jin's directory which reads audio in .au format from stdin. I used to distribute such a script (along with the real player - "sox") up until Jin 2.13. I then decided to deprecate the whole method and therefore stopped distributing that. You're free to write such a script yourself though, or get it from Jin 2.12.1.

         
    • Bob

      Bob - 2005-10-09

      Nothing is ever straightforward :)  But this may be of use to other users of the Ubuntu distribution.  I installed the polypaudio package which becomes the default sound daemon on installation.  Then I put the following file with the name "play" in my jin directory:

      #!/bin/sh
      paplay /dev/stdin

      and chmod 755.  (paplay comes with the polypaudio utilities package).

      This works absolutely perfectly; there is no detectable sound lag, and polypaudio handles multiple streams well.

      Thanks for the tip that sent me in the right direction!

       
      • Alexander Maryanovsky

        I'm glad things worked out for you.

         

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks