Hello to everyone!

Yesterday, after system update I couldn't boot my system anymore. I got the following kernel message:

Waiting 0 s before mounting root device...
JFS: nTxBlock = 8192, nTxLock = 65536
kinit: Mounted root (jfs filesystem) readonly.
kinit: /sbin/init: Too many symbolic links encountered
Kernel panic - not syncing: Attempting to kill init!
Pid: 1, comm: kinit Not tainted 2.6.30-ARCH #1
Call Trace
... (here go some hex numbers - i will type them if needed)

(BTW it is 64bit system)

Till now, I'm almost completely assured that problem is not in kernel because others who had similar problems solved it by booting live cd and using chrooted environment which I can't do (description follows).

I tried to boot live cd and try chrooted environment, but after mounting needed partitions and other, when i try "chroot arch_dir" i get:
chroot: cannot run command '/bin/bash': Too many levels of symbolic links

I managed to get into chrooted environment by replacing bash with dash which is statically linked so it doesn't require any other libs. But if I try to run any other dinamically linked app, I get the same error.

I've checked all libraries that ldd reports for bash and there is only one level of symbolic linking for each (for example /lib/libreadline.so.6 links to /lib/libreadline.so.6.0 which is needed library) which is the same like on other systems that work.

Also to mention, when I first tried to mount jfs volumes jfs_fsck reported that they are corrupted but marked as clean and to run it again with -f option. I did that and after that everything was ok and I was able to mount them to save some critical data I need for work.

Do you have any suggestions?

Igor Brkic