#1067 Regression in handling missing values in 1.0.14

1.0.x
closed-fixed
General (896)
7
2012-09-18
2011-11-29
Jon Doh
No

I don't know if this is deliberate, but 1.0.13 and 1.0.14 handle missing values differently. If one time series has all values missing, nothing is drawn on the chart, not even other time series.

Discussion

  • Jon Doh

    Jon Doh - 2011-11-29

    Java Test File

     
    Attachments
  • Jon Doh

    Jon Doh - 2011-11-29

    Output with JFreeChart 1.0.13

     
    Attachments
  • Jon Doh

    Jon Doh - 2011-11-29

    Output with JFreeChart 1.0.14

     
    Attachments
  • David Gilbert

    David Gilbert - 2011-11-30

    Thanks for the report - it sounds like a bug to me.

     
  • David Gilbert

    David Gilbert - 2011-11-30
    • assigned_to: nobody --> mungady
    • milestone: --> 1.0.x
    • labels: --> General
     
  • Martin Höller

    Martin Höller - 2011-12-16
    • priority: 5 --> 7
     
  • Martin Höller

    Martin Höller - 2011-12-16

    The problem seems to be in the new TimeSeriesCollection.getRangeBounds() method (since 1.0.14). This method uses result = Range.combine(result, r); where r is Range[NaN,NaN], The Range.combine() method doesn't deal with this situation and returns an invalid range of Range[NaN,NaN], no matter what the other range is.

    So the solution would be either fix Range.combine() in a way that it can handle NaN values, or make sure it is not called with NaN values from TimeSeriesCollection.getRangeBounds().

    David, you assigned this issue to yourself. If you find time to fix it, just do so. If I'll come up with a fix, I'll let you know.

     
  • David Gilbert

    David Gilbert - 2012-01-08
    • status: open --> closed-fixed
     
  • David Gilbert

    David Gilbert - 2012-01-08

    Fixed for the upcoming 1.0.15 release.

     
  • Martin Höller

    Martin Höller - 2012-04-03
    • status: closed-fixed --> open-accepted
     
  • David Gilbert

    David Gilbert - 2012-09-18
    • status: open-accepted --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks