#7 AntFarm does not use error parsing API correctly

closed-out-of-date
None
5
2006-08-30
2002-02-03
Anonymous
No

Using windows 98 and NT and jedit 3.2.2. When running
the following ant target, the console plugin displays
output correctly however regular expressions are not
being matched. They do not turn red, and I get a
BUILD sucessful, even through I can see the errors in
the console output.

<target name="Compile_EdocsBean">
<telnet userid="xx" password="xxxxxx" server="xx">
<read string="shtrain%"/>
<write>javac -d . EdocsBean.java</write>
<read string="shtrain%"/>
<write>logout</write>
</telnet>
</target>

Error messges in the console are in the form
file:linenumber:errormsg
Output from the javac line in the target above should
match the following, but do not. I also have tried
(.+) by itself with same results.

(.+):(\d+):(.+)

However, the same errors are caught (turn red) in the
console with the following target:

<target name="compile" depends="init">
<javac deprecation="on"
srcdir="${src}"
includes="edocs/**"
destdir="${build}"/>
</target>

I believe the bug is with the <telnet> tag. If the
telnet connection is unable to connect the error
message from it does get caught in the console, but
output from a telnet session is not being tested
aganist the regular expressions, it is just displayed
in the console.

Discussion

  • Nobody/Anonymous

    Logged In: NO

    using console version: 3.0.3
    ant version: 1.0.1

     
  • Slava Pestov

    Slava Pestov - 2002-02-11

    Logged In: YES
    user_id=2280

    assigning to AntFarm author since this is an AntFarm bug

     
  • Slava Pestov

    Slava Pestov - 2002-02-11
    • assigned_to: nobody --> brik
     
  • Slava Pestov

    Slava Pestov - 2003-05-23
    • assigned_to: brik --> jiwils
     
  • Slava Pestov

    Slava Pestov - 2003-05-29
    • assigned_to: jiwils --> nobody
    • milestone: 101608 -->
    • labels: 102671 -->
     
  • Brad Mace

    Brad Mace - 2003-06-17
    • assigned_to: nobody --> spestov
     
  • Slava Pestov

    Slava Pestov - 2003-09-08
    • assigned_to: spestov --> nobody
    • summary: console reg expressions do not work --> AntFarm does not use error parsing API correctly
     
  • Slava Pestov

    Slava Pestov - 2003-09-08

    Logged In: YES
    user_id=2280

    Why is this bug assigned to me? Its an AntFarm bug. It needs
    to send task output a line at a time to the Console.

     
  • Brad Mace

    Brad Mace - 2003-12-29
    • assigned_to: nobody --> jiwils
     
  • Alan Ezust

    Alan Ezust - 2006-08-30
    • status: open --> closed-out-of-date
     
  • Alan Ezust

    Alan Ezust - 2006-08-30

    Logged In: YES
    user_id=935841

    Should be fixed in antfarm 1.4.x.
    Please re-open the bug if you have problems.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks