#525 XClipboard doesn't work

minor bug
closed-fixed
nobody
5
2001-07-17
2001-07-06
No

The new all java version of XClipboard does not work for me with my setup. I'm using
jedit3.1, XClipboard 0.3, sun's 1.3.1 jdk on Mandrake8.0, and XFree 4.0.3.

When trying to paste in a highlighted bit of text from say an xterm window into jEdit I get this error:

[error] Exception occurred during event dispatching:
[error] gnu.x11.Error: X server connection error
[error] protocol-major-version: 11
[error] protocol-minor-version 0
[error] reason: Client is not authorized to connect to Server
[error] at gnu.x11.MessageFactory.build_connection_error(MessageFactory.java:50)
[error] at gnu.x11.MessageFactory.build_error(MessageFactory.java:58)
[error] at gnu.x11.MessageFactory.build(MessageFactory.java:255)
[error] at gnu.x11.Connection.read_message(Connection.java:342)
[error] at gnu.x11.Connection.read_reply(Connection.java:374)
[error] at gnu.x11.Display.read_reply(Display.java:718)
[error] at gnu.x11.Display.<init>(Display.java:187)
[error] at gnu.x11.Display.<init>(Display.java:97)
[error] at XClipboard.openXConnection(XClipboard.java:54)
[error] at XClipboard.<init>(XClipboard.java:49)
[error] at XClipboard.<clinit>(XClipboard.java:29)
[error] at XClipboardPlugin.mousePressed(XClipboardPlugin.java:61)
[error] at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:221)
[error] at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:220)
[error] at java.awt.Component.processMouseEvent(Component.java:3712)
[error] at java.awt.Component.processEvent(Component.java:3544)
[error] at java.awt.Container.processEvent(Container.java:1164)
[error] at java.awt.Component.dispatchEventImpl(Component.java:2593)
[error] at java.awt.Container.dispatchEventImpl(Container.java:1213)
[error] at java.awt.Component.dispatchEvent(Component.java:2497)
[error] at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:2451)
[error] at java.awt.LightweightDispatcher.processMouseEvent(Container.java:2210)
[error] at java.awt.LightweightDispatcher.dispatchEvent(Container.java:2125)
[error] at java.awt.Container.dispatchEventImpl(Container.java:1200)
[error] at java.awt.Window.dispatchEventImpl(Window.java:914)
[error] at java.awt.Component.dispatchEvent(Component.java:2497)
[error] at java.awt.EventQueue.dispatchEvent(EventQueue.java:339)
[error] at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:131)
[error] at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:98)
[error] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
[error] at java.awt.EventDispatchThread.run(EventDispatchThread.java:85)

I don't get this error when trying to paste into e.g. another xterm window.

Discussion

  • Todd Papaioannou

    Logged In: YES
    user_id=16728

    Interestingly, the second time I try to paste, I get a different error:
    [error] Exception occurred during event dispatching:
    [error] java.lang.NoClassDefFoundError
    [error] at XClipboardPlugin.mousePressed(XClipboardPlugin.java:61)
    [error] at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:221)
    [error] at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:220)
    [error] at java.awt.Component.processMouseEvent(Component.java:3712)
    [error] at java.awt.Component.processEvent(Component.java:3544)
    [error] at java.awt.Container.processEvent(Container.java:1164)
    [error] at java.awt.Component.dispatchEventImpl(Component.java:2593)
    [error] at java.awt.Container.dispatchEventImpl(Container.java:1213)
    [error] at java.awt.Component.dispatchEvent(Component.java:2497)
    [error] at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:2451)
    [error] at java.awt.LightweightDispatcher.processMouseEvent(Container.java:2210)
    [error] at java.awt.LightweightDispatcher.dispatchEvent(Container.java:2125)
    [error] at java.awt.Container.dispatchEventImpl(Container.java:1200)
    [error] at java.awt.Window.dispatchEventImpl(Window.java:914)
    [error] at java.awt.Component.dispatchEvent(Component.java:2497)
    [error] at java.awt.EventQueue.dispatchEvent(EventQueue.java:339)
    [error] at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:131)
    [error] at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:98)
    [error] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
    [error] at java.awt.EventDispatchThread.run(EventDispatchThread.java:85)

     
  • Andre Kaplan

    Andre Kaplan - 2001-07-17

    Logged In: YES
    user_id=1792

    Issuing:
    xhost +
    should solve the problem

     
  • Andre Kaplan

    Andre Kaplan - 2001-07-17
    • milestone: 101607 --> minor bug
    • status: open --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks