#3810 The comment character of JavaScript in HTML is wrong

minor bug
closed-fixed
5
2014-03-31
2013-07-03
funa take
No

<!-- --> will be inserted if range (or line) comment is used for JavaScript in HTML.
I expect /* */ (or //).

It seems that an indent function is not work, either.

Revison 23057

Discussion

  • Owain Formby

    Owain Formby - 2013-07-07

    Also incorrectly comments out PHP code, uses <!-- --> rather than // and /* */

     
  • Matthieu Casanova

    There is a regression somewhere, I think a change introduced in rev 20563 is the cause

     
  • Alan Ezust

    Alan Ezust - 2014-03-25
    • assigned_to: Dale Anson
    • Group: --> minor bug
     
  • Dale Anson

    Dale Anson - 2014-03-26

    I can't reproduce this issue. With the move of svn repositories recently, I can't find the change made in 20563.

     
  • Dale Anson

    Dale Anson - 2014-03-26
    • status: open --> closed-works-for-me
     
  • Dale Anson

    Dale Anson - 2014-03-26
    • status: closed-works-for-me --> open
     
  • Dale Anson

    Dale Anson - 2014-03-26

    Missed the part about "in HTML", I'll take another look at this.

     
  • Dale Anson

    Dale Anson - 2014-03-31

    I still can't reproduce this. I believe the changes introduced in revision 23418 handle this situation. That change fixed some mode delegation issues so that the proper syntax highlighting and mode properties were applied correctly to script tags in html.

     
  • Dale Anson

    Dale Anson - 2014-03-31
    • status: open --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks