#3784 MacOSX: jedit5 fonts look fuzzy

closed-fixed
Makarius
5
2014-07-04
2013-03-14
No

I've tried 5.0 and the most recent daily build and the fonts look fuzzy on MacOSX. Looks great on Red Hat Linux. I don't have access to a Windows machine.

I am running the latest version of Java 6. I've tried this on 3 different macs.

I attached screenshots for both versions. I had to take a screenshot of the screenshots because I can only attach 1 file.

Related

Bugs: #3784

Discussion

  • Makarius

    Makarius - 2013-03-15

    I have myself struggled a lot with the various possibilities of getting jEdit and Java on Mac OS X wrong by default. Note that in jedit-5.0.0 there have been some changes of defaults -- it also depends on the configuration of the MacOSX plugin, which is not part of the main code base.

    Here are the main parameters:

    * Java 6 with or without the .jedit/noquartz option -- the Apple Quartz font renderer does things differently, and often worse.

    * Java 7 instead of Java 6 -- version 7 is presently not officially supported by jedit-5.0.0, but you may try that one here: https://isabelle.in.tum.de/

    * Some soft Java options: according to my experience, antialias should be "standard" and fractional font metrics off (even though the comment says "for better smooth text display").

    Note that I am merely a commenter here. I hope we can all sit down together and sort out jEdit on Mac OS X problems soon. Java 6 has been declared dead by Oracle already, and proper Java 7 configuration needs some fine-tuning, not just font rendering quality.

     
  • Steven Scholnick

    I've resorted to keeping jEdit 4.5.2 on my Macs.

     
  • Alan Ezust

    Alan Ezust - 2013-04-04

    makarius, do you volunteer to help? We need another Mac developer on the team.

     
  • Steven Scholnick

    Sure no problem. I'd be happy to volunteer.

     
  • Makarius

    Makarius - 2013-04-04

    OK, I am here.

    Steven, I think it is as simple as disabling the Apple Quartz renderer of Java 6, which was enabled by default in jedit-5.0.0. You can do this by creating an empty file called "noquartz" in the jEdit settings directory, which is normally Library/jEdit/ within your home. There are technical reasons for doing it outside the normal jEdit properties. What is a bit odd in jedit-5.0.0 is that there is no regular way to change that setting, but I think some "trunk" version of the MacOS plugin can do it.

    Note that various issues about jEdit on Mac OS X were recently discussed on the thread on the jedit-dev mailing list thread "should jEdit 5.1 depend on Java 6 or 7?" I think we need a criticial mass of enthusiams to make moves towards modernized platform support here. It also touches the question about including MacOS plugin functionality into the main code base, but I am myself not an expert on that plugin. We should move this discussion elsewhere ...

     
  • Steven Scholnick

    makarius: that did the trick. Thanks!

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2013-06-12

    Thanks, makarius -- that noquartz trick worked great, and the extra detail around the causes of the bug are interesting too.

    I didn't know jedit was stuck on Java 6; I run it with openjdk 7 on my linux box.

     
  • Alan Ezust

    Alan Ezust - 2013-10-07

    makarius, this is fixed now, right?

     
  • Alan Ezust

    Alan Ezust - 2013-10-07
    • assigned_to: nobody --> makarius
    • labels: 102669 --> MacOSX specific
     
  • Makarius

    Makarius - 2013-10-09

    Yes, issue closed.

    With Java 7 none of these special rendering options have any effect. So it always looks right for a Linux or Windows person, even on the Mac. Some hardcore Mac users might complain that the style of font smoothing is not what Apple normally does, but this cannot be changed.

    What also works now out of the box in Java 7u40 is Retina high-resolution, without any special options as I've been told (I don't have such a display myself).

    These observations are relevant to the documentation / FAQ: for Mac OS X nothing special needs to be said.

     
  • Makarius

    Makarius - 2013-10-09
    • status: open --> open-fixed
     
  • Alan Ezust

    Alan Ezust - 2013-10-26
    • status: open-fixed --> closed-fixed
     
  • Steven Scholnick

    With the latest release and Java 7, this is back. :(

     
  • Makarius

    Makarius - 2014-07-04

    According to my understanding, the original problem cannot come back in Java 7, since Oracle has removed (or replaced) the font-renderer by Apple that was involved here.

    There might be other sources of bad text quality, though, notably the actual fonts being used and jEdit Options for anti-aliasing and fractional font metrics (the latter is generally bad).

    So what exactly are your versions / options precisely?

    . Java (according to dialog jEdit About);

    . Text Area font, e.g. Monospaced, Monaco, Deja Vu Sans are all bad, but Lucida Sans Typewriter is good;

    . jEdit Options for "Anti aliased smooth text" and "Fractional font metrics".

     
    • Steven Scholnick

      Java 1.7.0_60 (Oracle)
      Font: Dialog 12 Plain
      Anti Aliased Smooth Text: None
      Fractional Font Metrics: Not Checked

      This is a fresh install on a new Macbook Air.

      -steve

      On July 4, 2014 at 5:32:30 AM, Makarius (makarius@users.sf.net) wrote:

      According to my understanding, the original problem cannot come back in Java 7, since Oracle has removed (or replaced) the font-renderer by Apple that was involved here.

      There might be other sources of bad text quality, though, notably the actual fonts being used and jEdit Options for anti-aliasing and fractional font metrics (the latter is generally bad).

      So what exactly are your versions / options precisely?

      . Java (according to dialog jEdit About);

      . Text Area font, e.g. Monospaced, Monaco, Deja Vu Sans are all bad, but Lucida Sans Typewriter is good;

      . jEdit Options for "Anti aliased smooth text" and "Fractional font metrics".

      [bugs:#3784] MacOSX: jedit5 fonts look fuzzy

      Status: closed-fixed
      Group:
      Labels: MacOSX specific
      Created: Thu Mar 14, 2013 06:06 PM UTC by Steven Scholnick
      Last Updated: Thu Jul 03, 2014 12:37 PM UTC
      Owner: Makarius

      I've tried 5.0 and the most recent daily build and the fonts look fuzzy on MacOSX. Looks great on Red Hat Linux. I don't have access to a Windows machine.

      I am running the latest version of Java 6. I've tried this on 3 different macs.

      I attached screenshots for both versions. I had to take a screenshot of the screenshots because I can only attach 1 file.

      Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/jedit/bugs/3784/

      To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/

       

      Related

      Bugs: #3784

      • Alan Ezust

        Alan Ezust - 2014-07-04

        Try turning on subpixel antialiasing, it should look better then.

         

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks