JComException with HRESULT=0x8002801D

  • Nobody/Anonymous

    Every call that a make to the IDispach object i get the same error. I tried a word example and it worked fine.
    This error happens with the object of the examples. I tried with JIntegra and it worked fine. But when i try to do it using JCom i get an error.
    Have somebody a clue of what is happennig?

    IDispatch o = new IDispatch(rm, "SmartEpadSDK.SmartEpadHID");

    First case:   
    try {
    } finally {

    jp.ne.so_net.ga2.no_ji.jcom.JComException: IDispatch::GetTypeInfo() failed HRESULT=0x8002801DL
        at jp.ne.so_net.ga2.no_ji.jcom.IDispatch._getTypeInfo(Native Method)
        at jp.ne.so_net.ga2.no_ji.jcom.IDispatch.getTypeInfo(IDispatch.java:269)
        at test.device.smartepad.SmartEpadHID.main(SmartEpadHID.java:63)
    Exception in thread "main"

    Other example:
    try {
       o.method("unitialize", null);
    } finally {

    jp.ne.so_net.ga2.no_ji.jcom.JComException: IDispatch::GetIDsOfNames(Unitialize) failed HRESULT=0x8002801D
        at jp.ne.so_net.ga2.no_ji.jcom.IDispatch._getIDsOfNames(Native Method)
        at jp.ne.so_net.ga2.no_ji.jcom.IDispatch.method(IDispatch.java:222)
        at test.device.smartepad.SmartEpadHID.main(SmartEpadHID.java:65)
    Exception in thread "main"

    • Philippe Ombredanne

      I will look into it tomorrow.
      Is there a way to get the SmartEpadSDK.SmartEpadHID
      Com object somewhere to give it a spin?
      Some trial download?


      philippe ombredanne | nexB - Open IT Asset Management
      1 650 799 0949 | pombredanne at nexb.com

    • Nobody/Anonymous

      Yes it is. The SmartEpadSDK contains the DLL with the COM objects.

      Thank you for your quick answer

    • Nobody/Anonymous


      When i try to quit the JCOM JComException: IDispatch::GetIDsOfNames(Unitialize) error is coming, If you have any solution for this please reply to thread itself.

      Thanking in Advance


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks